Wie behebe ich unerwartete Neustarts oder Failovers für meine Aurora MySQL-Compatible-DB-Instances?
Ich möchte Fehler beheben und unerwartete Neustarts oder Failovers für meine Amazon Aurora MySQL-Compatible Edition-DB-Instance verhindern.
Kurzbeschreibung
Unerwartete Neustarts von Aurora MySQL-kompatiblen DB-Instances können aus den folgenden Gründen auftreten:
- Ressourcenkonflikte und hoher Workload
- Nebenversionen oder Patch-Upgrades und zugrundeliegende Betriebssystem (OS)-Patches
- Manuelle Neustarts und Neustarts der Datenbank-Engine
- Probleme mit der Infrastruktur
- Übermäßiger Workload
- Vertikale Skalierung
- Anforderungen an die Wartung
Um sicherzustellen, dass deine DB-Instance den Betrieb fortsetzt, führt Aurora ein Failover auf das Lesereplikat durch, das die höchste Priorität oder die niedrigste Stufe hat. Weitere Informationen findest du unter Fehlertoleranz für einen Aurora-DB-Cluster.
Lösung
Wichtig: Performance Insights wird am 30. Juni 2026 das Ende seiner Lebensdauer erreichen. Du kannst vor dem 30. Juni 2026 ein Upgrade auf den Modus „Erweitert“ von Database Insights durchführen. Wenn du kein Upgrade durchführst, verwenden DB-Cluster, die Performance Insights verwenden, standardmäßig den Modus „Standard“ von Database Insights. Nur der Modus „Erweitert“ von Database Insights unterstützt Ausführungspläne und On-Demand-Analysen. Wenn die Cluster standardmäßig auf den Modus „Standard“ eingestellt sind, kannst du diese Funktionen möglicherweise nicht auf der Konsole verwenden. Informationen zum Aktivieren des Modus „Erweitert“ findest du unter Aktivieren des Modus „Erweitert“ von Database Insights für Amazon RDS und Aktivieren des Modus „Erweitert“ von Database Insights für Amazon Aurora.
Ressourcenkonflikte und hoher Workload
Wenn ein unerwarteter Neustart aufgrund von Ressourcenkonflikten erfolgt, z. B. aufgrund von zu wenig verfügbarem Arbeitsspeicher oder hoher CPU-Auslastung, ergreife die folgenden Maßnahmen:
- Verwende Amazon CloudWatch, um deine Aurora MySQL-kompatiblen DB-Instance-Ressourcenmetriken proaktiv zu überwachen. Richte CloudWatch-Alarme ein, damit du benachrichtigt wirst, wenn die Ressourcennutzung die definierten Schwellenwerte überschreitet.
- Verwende Amazon RDS Enhanced Monitoring, um die Speichernutzung, Festplatten-E/A und CPU-Auslastung auf Betriebssystemebene zu überwachen.
- Verwende das Diagramm zur Datenbanklast (DB-Last) in Performance Insights, um ressourcenintensive Abfragen zu identifizieren und zu optimieren. Überprüfe dann die Datenbanknutzungsmuster deiner Anwendung.
Wenn dein Workload ständig eine hohe Menge an Ressourcen verbraucht, skaliere hoch auf einen größeren Instance-Typ mit mehr CPU-, Arbeitsspeicher- oder Speicherkapazität. Optimiere die Abfragen und die Arbeitslast für deine Datenbank-Instance. Verwende beispielsweise Caching oder andere Techniken zur Abfrageoptimierung, um die Belastung deiner DB-Instance zu reduzieren.
Nebenversionen oder Patch-Upgrades und zugrundeliegende Betriebssystem-Patches
Damit deine DB-Instance ordnungsgemäß funktioniert, führt Aurora während deines Cluster-Wartungsfensters Wartungsarbeiten an deiner Instance durch. Diese Wartung kann kleinere Versionen oder Patch-Upgrades sowie zugrundeliegende Betriebssystem-Patches beinhalten. Wenn während des Cluster-Wartungsfensters ein unerwarteter Neustart erfolgt, ist der Neustart möglicherweise Teil einer geplanten Systemaktualisierung oder Wartungsaufgabe. Passe dein Wartungsfenster an, um zukünftige unerwartete Neustarts oder Failovers zu verhindern.
Manuelle Neustarts und Neustarts der Datenbank-Engine
Um das Neustartproblem besser beheben zu können, musst du herausfinden, warum ein unerwarteter Neustart stattgefunden hat. Überprüfe die Amazon Relational Database Service (Amazon RDS)-Ereignisse zum Zeitpunkt des Neustarts. Oder du kannst AWS CloudTrail verwenden, um die API-Aufrufe für den Ereignisverlauf zu überprüfen. Du kannst auch die Datenbankfehlerprotokolle überprüfen, um die Ursache für den unerwarteten Neustart zu ermitteln. Achte zum Zeitpunkt des Neustarts auf Fehlermeldungen oder Warnungen im Zusammenhang mit Ressourcenkonflikten, Systemproblemen oder anderen möglichen Ursachen.
Weitere Schritte zur Fehlerbehebung
Weitere Schritte zur Fehlerbehebung findest du in den Versionshinweisen für Aurora MySQL-Compatible-Patches. Die Versionshinweise enthalten alle Korrekturen für Probleme, die in früheren Versionen von Aurora MySQL-Compatible aufgetreten sind. Wenn du eine neuere Version verwendest, suche nach Problemen, die der Ursache des unerwarteten Neustarts ähneln.
- Sprache
- Deutsch

Relevanter Inhalt
AWS OFFICIALAktualisiert vor einem Jahr