Direkt zum Inhalt

Wie behebe ich Endpunktprobleme, die dazu führen, dass meine AWS-DMS-Migrationsaufgaben fehlschlagen?

Lesedauer: 4 Minute
0

Meine AWS Database Migration Service (AWS DMS)-Aufgabe schlägt während der Phasen „Full Load“ und Change Data Capture (CDC) fehl und ich erhalte Endpunktprobleme und datenbankspezifische Fehler.

Lösung

Endpunktkonfiguration für die Konnektivität überprüfen

Gehe wie folgt vor, um die Konnektivität des Quell- oder Zielendpunkts deiner Aufgabe anzuzeigen:

  1. Öffne die AWS DMS-Konsole.
  2. Wähle im Navigationsbereich Migrieren oder replizieren aus.
  3. Wähle Aufgaben und dann deine Aufgabe aus.
  4. Überprüfe auf der Registerkarte Details im Abschnitt Konnektivität und Sicherheit den Namen der Replikations-Instance, um sicherzustellen, dass du die richtige Replikations-Instance verwendest.
  5. Wähle im Abschnitt Übersicht den Quell- oder Zielendpunkt aus, um die Endpunktschnittstelle zu überprüfen.
  6. Wähle die Registerkarte Verbindungen und dann Verbindungen testen aus.
  7. Wähle die Replikations-Instance und dann Test ausführen aus.

Wenn der Konnektivitätstest aufgrund einer Netzwerkkonfiguration den Status Fehlgeschlagen zurückgibt, erhältst du die folgenden Timeout-Fehlermeldungen:

Für Oracle:

„Test Endpoint failed: Application-Status: 1020912, Application-Message: ORA-12170: TNS:Connect timeout occurred OCI connection failure.“

Für PostgreSQL:

„Test Endpoint failed: Application-Status: 1020912, Application-Message: Failed to connect Network error has occurred, Application-Detailed-Message: RetCode: SQL_ERROR SqlState: 08001 NativeError: 101 Message: “

Für Amazon DocumentDB (mit MongoDB-Kompatibilität):

„Test Endpoint failed: Application-Status: 1020912, Application-Message: Failed to create new client connection Failed to connect to database., Application-Detailed-Message: Error verifying connection“

Weitere Informationen zur Behebung dieses Problems findest du unter Wie behebe ich Probleme mit der AWS-DMS-Endpunktkonnektivität? Teste die Verbindung dann erneut.

Endpunktauthentifizierungskonfiguration überprüfen

Der Konnektivitätstest des AWS-DMS-Endpunkts zeigt möglicherweise eine Authentifizierungsfehlermeldung an. Um eine Authentifizierungsfehlermeldung zu beheben, überprüfe, ob du den Zugriff auf deinen AWS-DMS-Endpunkt richtig konfiguriert hast.

Führe die folgenden Schritte aus:

  1. Öffne die AWS DMS-Konsole.
  2. Wähle im Navigationsbereich Migrieren oder replizieren aus.
  3. Wähle Endpunkte aus und wähle dann deinen Endpunkt aus.
  4. Wähle Aktionen und dann Ändern aus.
  5. Überprüfe im Abschnitt Endpunktkonfiguration die folgenden Angaben für Zugriff auf Endpunktdatenbank:
    Wenn du Zugriffsinformationen manuell angeben ausgewählt hast, überprüfe, ob der Host, den du im Feld Servername definiert hast, keine Ports (3306) oder Protokolle (HTTP) enthält. Stelle sicher, dass du denselben Nutzernamen, dasselbe Passwort und dieselben SSL-Werte in deiner Datenbank angegeben hast.
    Wenn du AWS Secrets Manager ausgewählt und das richtige Secret sowie den richtigen SSL-Modus ausgewählt hast, lies Allgemeine AWS-DMS-Voraussetzungen und Amazon VPC-Endpunkt mit AWS Secrets Manager einrichten.
    Wenn du Kerberos-Authentifizierung ausgewählt und den richtigen Servernamen, Port und Nutzernamen verwendet hast, lies Voraussetzungen und Einschränkungen bei der Verwendung der Kerberos-Authentifizierung mit AWS DMS.
    Wenn du IAM-Authentifizierung ausgewählt und den richtigen Servernamen, Port, Nutzernamen und die richtige AWS Identity and Access Management (IAM)-Rolle verwendet hast, überprüfe, ob du die richtigen Richtlinien an die IAM-Rolle angefügt hast. Weitere Informationen findest du auf der Registerkarte DMS-Konsole unter IAM-Authentifizierung für Amazon RDS-Endpunkt in AWS DMS konfigurieren und Einschränkungen für die IAM-Datenbankauthentifizierung.

Endpunkteinstellungen und ECAs überprüfen

Wenn du beim Ausführen deiner Aufgabe eine Oracle Pluggable Database (PDB) als Quelle verwendest, erhältst du möglicherweise die folgende Fehlermeldung:

„Test Endpoint failed: Application-Status: 1020912, Application-Message: Log Miner is not supported in Oracle PDB environment Endpoint initialization failed.“

Dieser Fehler tritt auf, weil du die Replikationsmethode als Log Miner statt als Binary Reader konfiguriert hast.

Gehe wie folgt vor, um die Replikationsmethode zu ändern, die die AWS-DMS-Aufgabe verwendet:

  1. Öffne die AWS DMS-Konsole.
  2. Wähle im Navigationsbereich Migrieren oder replizieren aus.
  3. Wähle Aufgaben und dann deine Aufgabe aus.
  4. Wähle im Abschnitt Übersicht den Link zur Anweisungsquelle aus.
  5. Wähle Aktionen und dann Ändern aus.
  6. Wähle unter Endpunkteinstellungen die Option Endpunktverbindungsattribute verwenden aus.
  7. Um die Replikationsmethode als Binary Reader zu konfigurieren, gib das Attribut useLogMinerReader=N;useBfile=Y; in das Feld Zusätzliche Verbindungsattribute (ECAs) ein.
  8. Wähle Speichern aus.

Abfrage-Timeout-Fehler überprüfen

Wenn du deine AWS-DMS-Aufgabe startest, erhältst du möglicherweise die folgende PostgreSQL-Abfrage-Timeout-Fehlermeldung:

„]E: RetCode: SQL_ERROR SqlState: 57014 NativeError: 1 Message: ERROR: canceling statement due to statement timeout; Error while executing the query [1022502] (ar_odbc_stmt.c:2738)“

Gehe wie folgt vor, um den Parameter executeTimeout in der Quelldatenbank für die AWS-DMS-Aufgabenanforderungen anzupassen:

  1. Öffne die AWS DMS-Konsole.
  2. Wähle im Navigationsbereich Endpunkte aus und wähle dann deinen Endpunkt aus.
  3. Wähle Aktion und dann Ändern aus.
  4. Wähle im Abschnitt Endpunkteinstellungen die Option Endpunktverbindungsattribute verwenden aus.
  5. Um einen benutzerdefinierten executeTimeout zu konfigurieren, gib executeTimeout=3600; in das Feld Zusätzliche Verbindungsattribute (ECAs) ein.
  6. Wähle Speichern aus.

Wenn weiterhin Timeout-Probleme auftreten, lies Wie kann ich eine AWS-DMS-Aufgabe beheben, die mit der Fehlermeldung „ERROR: canceling statement due to statement timeout“ fehlschlägt?

Ähnliche Informationen

Arbeiten mit AWS DMS-Endpunkten

Quell- und Zielendpunkte erstellen

Erweiterte Endpunktkonfiguration

AWS OFFICIALAktualisiert vor 7 Monaten