Direkt zum Inhalt

Wie behebe ich Fehler, wenn ich einen ElastiCache-Cluster erstelle?

Lesedauer: 6 Minute
0

Wenn ich einen Amazon ElastiCache-Cluster erstelle, schlägt die Erstellung fehl.

Kurzbeschreibung

Je nachdem, ob es sich bei dem Cluster um einen selbst entworfenen oder einen Amazon ElastiCache Serverless-Cluster handelt, kann die Clustererstellung aus den folgenden Gründen fehlschlagen:

  • Du stellst ein Backup von Amazon Simple Storage Service (Amazon S3) wieder her, aber die Wiederherstellung schlägt aufgrund eines Fehlers fehl.
  • In einer Availability Zone oder AWS-Region ist nicht genügend Kapazität für den angeforderten Cache-Knotentyp vorhanden.
  • Du hast einen Cache-Knotentyp ausgewählt, der in einer bestimmten Availability Zone der Region nicht unterstützt wird.
  • In dem Subnetz, das du für die Cache-Cluster-Erstellung verwendet hast, gibt es nicht genügend freie IP-Adressen.
  • ElastiCache kann nicht auf den kundenverwalteten Schlüssel von AWS Key Management Service (AWS KMS) zugreifen, den du zum Verschlüsseln einer Replikationsgruppe verwendet hast.
  • Die Cache ist nicht berechtigt, einen Virtual Private Cloud (VPC)-Endpunkt für ElastiCache Serverless zu erstellen.
  • Der Benutzer oder die Rolle von AWS Identity and Access Management (IAM) hat nicht die richtigen Berechtigungen.
  • Für die AWS-Konto ist ein höheres Servicekontingent erforderlich.
  • Du hast die Engine-spezifischen Parameter bei der Clustererstellung falsch konfiguriert.

Lösung

Hinweis: Wenn du beim Ausführen von AWS Command Line Interface (AWS CLI)-Befehlen Fehlermeldungen erhältst, findest du weitere Informationen dazu unter Problembehandlung bei AWS CLI-Fehlern. Stelle außerdem sicher, dass du die neueste Version der AWS CLI verwendest.

Die Wiederhesrstellung des Amazon S3-Backups schlägt aufgrund eines Fehlers fehl

Die Wiederherstellung eines Backups von Amazon S3 kann aus verschiedenen Gründen fehlschlagen. Beispielsweise kann ElastiCache die Datei nicht abrufen, oder der Bucket befindet sich in einer anderen Region. Um diesen Fehler zu beheben, gehe zu „Erstellen fehlgeschlagen“ oder „Erlaubnis verweigert“, der auftritt, wenn ich versuche, meinen ElastiCache-Cluster aus S3 wiederherzustellen?

In einer Availability Zone oder Region ist nicht genug Kapazität für den angeforderten Cache-Knotentyp vorhanden

Wenn AWS nicht über genügend On-Demand-Kapazität verfügt, erhältst du möglicherweise die folgende Fehlermeldung, wenn du einen Cluster erstellst:

„Der Cache-Knoten konnte nicht erstellt werden, da die angeforderte AZ nicht über ausreichende Kapazität verfügt. Bitte versuche es erneut mit einer anderen AZ.“

Die Kapazität in einer Availability Zone oder Region ändert sich ständig. Um dieses Problem zu beheben, erstelle den Cluster zu einem anderen Zeitpunkt. Weitere Informationen findest du unter Fehlermeldungen: InsufficientCacheClusterCapacity.

Eine Availability Zone der Region unterstützt den Cache-Knotentyp nicht

Einige Availability Zones in einer Region unterstützen bestimmte Cache-Knotentypen nicht. Wenn du einen Cluster erstellst und eine dieser Availability Zones auswählen, erhälst du die folgende Fehlermeldung:

„Der Cache-Knotentyp wird derzeit in der AZ nicht unterstützt. Versuche den Start erneut ohne Availability Zone oder mit einer anderen AZ.“

Verwende den AWS-CLI-Befehl describe-instance-type-offerings von Amazon Elastic Compute Cloud (Amazon EC2), um die Verfügbarkeit eines bestimmten Cache-Knotentyps zu überprüfen:

aws ec2 describe-instance-type-offerings --location-type availability-zone --filters Name=instance-type,Values=m5.large --region example-region --output table

**Hinweis:**Ersetze example-region durch deine Region.

In dem von dir ausgewählten Subnetz gibt es nicht genügend freie IP-Adressen

Wenn die Subnetze, die du für den ElastiCache-Cluster verwendest, nicht über genügend freie IP-Adressen verfügen, wird möglicherweise die folgende Fehlermeldung angezeigt:

„Erstellen eines Cache-Clusters fehlgesschlagen, da das Elastic Network Interface oder die freie IP-Adresse nicht ausreichen“

Um dieses Problem zu beheben, identifiziere die Subnetzgruppe, die du für den ElastiCache-Cluster konfiguriert hast. Überprüfe dann jedes Subnetz, um sicherzustellen, dass genügend freie IP-Adressen vorhanden sind. Weitere Informationen findest du unter Wie behebe ich Fehler bei nicht ausreichender IP-Adresse, die während der Skalierung in meiner Amazon VPC auftreten?

Um IP-Adressen freizugeben, kannst du auch ungenutzte Elastic-Network-Schnittstellen in einem Subnetz löschen. Oder füge der Subnetzgruppe in der erforderlichen Availability Zone-Subnetze hinzu, um mehr freie IP-Adressen zuzuweisen.

ElastiCache kann nicht auf den vom Kunden verwalteten AWS-KMS-Schlüssel zugreifen

Mit der ElastiCache-Verschlüsselung im Ruhezustand kannst du eine standardmäßige, vom Service verwaltete Verschlüsselung im Ruhezustand oder deinen eigenen symmetrischen, vom Kunden verwalteten AWS-KMS-Schlüssel verwenden. Wenn du beim Erstellen des Clusters die Berechtigungen für den KMS-Schlüssel gelöscht, deaktiviert oder widerrufen hast, wird möglicherweise die folgende Fehlermeldung angezeigt:

„Fehler beim Erstellen des Instance-Test-Clusters aufgrund eines Fehlers beim Zugriff auf den AWS Key Management Service (KMS) für den Kundenmasterschlüssel arn:aws:kms:us-east- 1:123456:key/1abcd2“

Es ist keine bewährte Methode, Berechtigungen für den AWS-KMS-Schlüssel, den du zum Verschlüsseln einer Replikationsgruppe verwendet hast, zu löschen, zu deaktivieren oder zu widerrufen. AWS KMS löscht Root-Schlüssel erst nach einer Wartezeit von mindestens sieben Tagen. Während der Wartezeit kannst du das geplante Löschen stornieren. Wenn du den AWS-KMS-Schlüssel löscht, kannst du den Cache nicht wiederherstellen.

Die ElastiCache Serverless-Cache ist nicht berechtigt, einen VPC-Endpunkt zu erstellen

Wenn du einen neuen ElastiCache Serverless-Cluster erstellst, erstellt ElastiCache-VPC-Endpunkte in den ausgewählten Subnetzen der VPC. Die Anwendungen verwenden die VPC-Endpunkte, um eine Verbindung zum Cache herzustellen. Wenn die Cache die VPC-Endpunkte nicht erstellen können, gibt es möglicherweise Berechtigungsprobleme. Informationen zur Behebung von Berechtigungsproblemen findest du unter Wie behebe ich Probleme bei der Clustererstellung mit ElastiCache Serverless?

Der IAM-Benutzer oder die IAM-Rolle hat nicht die richtigen Berechtigungen

Wenn die IAM-Benutzer oder die IAM-Rolle nicht über die richtigen Berechtigungen verfügt, wird möglicherweise die folgende Fehlermeldung angezeigt:

„An error occurred (AccessDenied) when calling the CreateReplicationGroup operation: User: arn:aws:sts::xxxxxxxxx:assumed-role/Hello123 is not authorized to perform: elasticache:CreateReplicationGroup on resource: arn:aws:elasticache:ap-southeast-2:xxxxxxxxxx:replicationgroup:ROLEA because no identity-based policy allows the elasticache:CreateReplicationGroup action.“

Wenn du eine benutzerdefinierte IAM-Richtlinie mit ElastiCache verwendest, führe eine der folgenden Aktionen aus:

Für das AWS-Konto ist ein höheres Servicekontingent erforderlich

Das Konto hat Standardkontingente für jeden AWS-Service und jedes Kontingent ist spezifisch für die Region.

Wenn das Konto nicht über das erforderliche Servicekontingent verfügt, wird möglicherweise eine der folgenden Fehlermeldungen angezeigt:

  • „Cache subnet group quota exceeded. You can have at most 500 cache subnet groups in this region. If you need more, please visit the Support Center and open a Service Limit Increase case.“
  • „Customer node quota exceeded. You can have at most 1250 nodes in this region. If you need more, please visit the Support Center and open a Service Limit Increase case.“

Für einige Kontingente kannst du Erhöhungen beantragen. Informationen zu Kontingenten und zur Erhöhung der Kontingente findest du unter Kontingente für ElastiCache.

Du hast die Engine-spezifischen Parameter falsch konfiguriert

Wenn du keine spezifische Parametergruppe für die Engine-Version angegeben hast, wird möglicherweise die folgende Fehlermeldung angezeigt:

„An error occurred (InvalidParameterCombination) when calling the CreateReplicationGroup operation: Expected a parameter group of family redis7 but found one of family redis6.x. User has to verify that Parameter Group used has engine version that matches the cluster that is created.“

Wenn du einen ElastiCache-Cluster erstellst, stelle sicher, dass die richtige Parametergruppe der Engine-Version und dem Typ des Cluster-Modus entspricht.

Ähnliche Informationen

So funktioniert Elasticache

AWS OFFICIALAktualisiert vor einem Jahr