AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
Warum kann ich Fleet Manager Remote Desktop nicht verwenden, um eine Verbindung zu meiner Amazon-EC2-Windows-Instance herzustellen?
Ich möchte Fleet Manager, eine Funktion von AWS Systems Manager, verwenden, um über das Remote Desktop Protocol (RDP) eine Verbindung zu meiner Amazon Elastic Compute Cloud (Amazon EC2)-Windows-Instance herzustellen.
Lösung
**Voraussetzungen:**Stelle sicher, dass du die folgenden Bedingungen erfüllst:
- Die Instance erfüllt die Anforderungen an die Umgebung. Das musst du tun, bevor du Remote Desktop verwendest.
- Deine Instance wird in der Systems-Manager-Konsole aufgeführt. Deine Instance muss im Abschnitt Fleet Manager unter Verwaltete Knoten aufgeführt sein.
- Der Ping-Status von AWS-Systems-Manager-Agent (SSM Agent) ist Online. Wenn deine Instance in Systems Manager nicht als verwaltet angezeigt wird oder wenn der Ping-Status Verbindung getrennt lautet, dann führe die Schritte unter Fehlerbehebung bei einem Offline-SSM-Agent aus.
Behebe Verbindungsprobleme basierend auf dem Fehler, den du beim Herstellen der Verbindung zu deiner Instance erhältst.
Fehler vom Typ „AccessDeniedException“ beheben
Der AWS Identity and Access Management (IAM)-Benutzer oder die IAM-Rolle, mit der du auf die Systems-Manager-Konsole zugreifst, muss Berechtigungen für die folgenden Aktionen haben:
- ssm-guiconnect:CancelConnection
- ssm-guiconnect:GetConnection
- ssm-guiconnect:StartConnection
Der folgende Fehler zeigt an, dass du die erforderlichen Berechtigungen nicht konfiguriert hast:
„AccessDeniedException: User: arn:aws:iam::123456789:user/ssmtest is not authorized to perform: ssm-guiconnect:StartConnection on resource: arn:aws:ec2:us-west-2:123456789:instance/*"
Um diesen Fehler zu beheben, konfiguriere die erforderlichen Berechtigungen.
Fehler vom Typ „Unable to establish Remote Desktop connection“ beheben
Im Fleet Manager Remote Desktop-Fenster kann die folgende Fehlermeldung angezeigt werden:
„Unable to establish Remote Desktop connection. Verify that valid credentials were provided, and that the user you specified has been granted permission to log in through Remote Desktop.“
Dieser Fehler weist auf eines der folgenden Probleme hin:
- Dein Benutzername oder Passwort ist falsch.
- Dein AWS-Konto ist deaktiviert.
- Du hast den Standard-RDP-Port (3389) geändert.
- Dein Passwort für das lokale Konto oder das Domain-Konto ist abgelaufen.
- Network Level Authentication (NLA) verursacht Authentifizierungsfehler.
- Remote Desktop Services wurde neu gestartet oder angehalten.
Gehe wie folgt vor, um diesen Fehler zu beheben:
-
Prüfe, ob du deine Anmeldeinformationen korrekt eingegeben hast.
-
Stelle sicher, dass das Benutzerkonto in deiner Active Directory-, lokalen Benutzer- und Gruppenverwaltung aktiv ist.
-
Führe den folgenden PowerShell-Befehl aus, um zu prüfen, ob der RDP-Port auf 3389: gesetzt ist.
PS> (Get-ItemProperty -Path 'HKLM:\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp' -name "PortNumber").PortNumberWenn der Port nicht auf 3389 gesetzt ist, führe den folgenden PowerShell-Befehl aus, um den richtigen Standardport zu konfigurieren:
PS> Set-ItemProperty -Path 'HKLM:\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp' -name "PortNumber" -Value 3389 PS> Restart-Service TermService -force -
Verwende einen RDP-Client, um dich über ein anderes Konto mit der Instance zu verbinden. Wenn das Passwort für dein lokales Konto abgelaufen ist, verwende das Tool lusrmgr.msc, um das Passwort zurückzusetzen. Wenn das Passwort für dein Domänenkonto abgelaufen ist, kontaktiere den Administrator der Domäne oder des Systems, um das Passwort zurücksetzen zu lassen.
-
Führe die Lösungsschritte im Abschnitt NLA is turned on for the server (NLA ist für den Server aktiviert) unter How do I troubleshoot authentication errors when I use RDP to connect to an EC2 Windows instance? (Wie behebe ich Authentifizierungsfehler, wenn ich RDP verwende, um eine Verbindung zu einer EC2-Windows-Instance herzustellen?) aus.
-
Führe die folgenden PowerShell-Befehle aus, um Remote Desktop Services neu zu starten:
PS> Get-Service TermService PS> Start-Service TermService
Fehler vom Typ „The remote desktop connection request timed out“ beheben
Die folgende Fehlermeldung zeigt an, dass du SSM Agent auf eine neuere Version aktualisieren musst. Weitere Ursachen für diese Fehlermeldung sind eine hohe CPU-Auslastung, erschöpfter Arbeitsspeicher und wenig Speicherplatz:
„The remote desktop connection request timed out. Try again.“
Gehe wie folgt vor, um diesen Fehler zu beheben:
- Stelle sicher, dass auf den Knoten SSM Agent Version 3.0.222.0 oder höher ausgeführt wird. Informationen zur Überprüfung der Versionsnummer des SSM-Agenten, der auf einem verwalteten Knoten installiert ist, findest du unter Überprüfen der SSM-Agent-Versionsnummer. Informationen zur Installation oder Aktualisierung des SSM-Agents findest du unter Arbeiten mit dem SSM-Agent.
- Überprüfe deine Amazon-CloudWatch-Metriken auf hohe CPU-Auslastung. Wenn deine Auslastung nahe bei 100 % liegt, verwende den RDP-Client, um den Prozess, der zu viele CPU-Ressourcen verwendet, zu identifizieren und beheben. Wenn du dich nicht anmelden kannst, starte die Instance neu. Nachdem du deine Instance erfolgreich neu gestartet hast, behebe die hohe CPU-Auslastung.
- Prüfe auf Betriebssystemebene, ob eine hohe Arbeitsspeicherauslastung vorliegt. Wenn dein Arbeitsspeicher erschöpft ist, starte die Instance neu.
- Wenn du den Fehler nach dem Neustart der Instance weiterhin erhältst, prüfe, ob auf dem Root-Volume genügend Speicherplatz vorhanden ist.
Fehler vom Typ „The connection has been terminated due to inactivity“ beheben
Fehler vom Typ „The connection has been terminated due to inactivity“ weisen darauf hin, dass deine RDP-Verbindung getrennt wurde, nachdem sie länger als 10 Minuten inaktiv war. Stelle sicher, dass die Bedingung, die du während deiner getrennten Remote-Desktop-Verbindung angewendet hast, nicht dazu führt, dass RDP getrennt wird.
Verbindungen beheben, die nach 60 Minuten getrennt werden
Fleet-Manager-Sitzungen werden standardmäßig nach 60 Minuten getrennt. Um zu prüfen, ob deine Sitzung getrennt wurde, weil sie das Zeitlimit erreicht hat, sieh dir die Informationen zu deinem Verbindungsverlauf an. Suche nach dem Status Zeitlimit überschritten, der der Verbindungs-ID deiner Instance entspricht.
Damit deine Sitzung verbunden bleibt, öffne das Menü Aktionen und wähle in der Drop.down-Liste Sitzung erneuern, bevor Remote Desktop die Verbindung trennt. Gib dann deinen Benutzernamen und dein Passwort ein und wähle die Schaltfläche Sitzung erneuern. Wenn du deine Verbindung erneuerst, wird der Dauer-Timer zurückgesetzt.
Deine RDP-Sitzungsverbindung kann auch enden, weil Amazon EC2 über die bestehende aktive RDP-Sitzung heruntergefahren oder neu gestartet wird.
Fehler vom Typ „TargetNotConnected“ beheben
Der folgende Fehler zeigt an, dass deine Instance offline ist oder beim Verbindungsaufbau in den Status booting (wird gestartet) wechselt:
„400: The StartSession API operation didn't succeed: An error occurred (TargetNotConnected) when calling the StartSession operation: example_instance_id is not connected.“
Stelle sicher, dass sich deine Instance im Status running (wird ausgeführt) befindet, nachdem beide Statusprüfungen bestanden wurden, und dass ihr Ping-Status in Fleet Manager Online lautet.
Anmeldefehler bei Single Sign-On (SSO) beheben
Der folgende Fehler zeigt an, dass SSO dort, wo du die Autorisierung anforderst, nicht konfiguriert ist oder nicht unterstützt wird:
„An error occurred while establishing the Remote Desktop Connection. The system cannot create an operating system for the SSO Login. The SSO functionality is not supported on the Domain controllers. You can only connect with username/password method.“
Um diesen Fehler zu beheben, verwende Benutzername und Passwort, um dich mit der Instance zu verbinden, oder kontaktiere den Domainadministrator deiner Organisation.
Ähnliche Informationen
- Themen
- Management & Governance
- Sprache
- Deutsch

Relevanter Inhalt
AWS OFFICIALAktualisiert vor einem Jahr