How do I disable daily automated backup for RDS?

0

I have setup an AWS Backup rule to backup a MariaDB instance:

  • hourly At 50 minutes past the hour
  • Start within 1 hour, complete within 2 hours
  • Total retention period is 2 days
  • continuous backup disabled But there are a few backup failed at the interval of 1:50, 2:50, 3:50 UTC: AWS Backukp-> Jobs

When I clicked on the hyperlink of the job that failed, the error is: Invalid lifecycle: Backup job 6A26EC48-D3CC-7DB9-2E2B-E962B0863DCA could not start because it is either inside or too close to the automated backup window configured in RDS instance.

On RDS->Automated Backup, I can see that the rds is backuped every hour. But I have checked there is no automated turned on for that rds database instance (RDS->Database->Modify). How can I disable that automated backup? Enter image description here

Cheers

profile picture
Lottie
preguntada hace 6 meses442 visualizaciones
1 Respuesta
0

Modify your RDS instance and set the backup retention to 0 days. That will disable the daily backups.

However you may need to have it enabled if your example your converting to Multi AZ etc.

profile picture
EXPERTO
respondido hace 6 meses
  • Did this answer your question?

No has iniciado sesión. Iniciar sesión para publicar una respuesta.

Una buena respuesta responde claramente a la pregunta, proporciona comentarios constructivos y fomenta el crecimiento profesional en la persona que hace la pregunta.

Pautas para responder preguntas