Passer au contenu

Comment résoudre les échecs de vérification d'état de mon instance Amazon EC2 ?

Lecture de 5 minute(s)
0

Une ou plusieurs vérifications d'état de mon instance Amazon Elastic Compute Cloud (Amazon EC2) ont échoué.

Brève description

Amazon EC2 utilise trois vérifications d'état pour surveiller l'état des instances EC2 :

Important : certaines résolutions de vérification d'état vous obligent à arrêter et à démarrer votre instance. Un redémarrage permet de conserver l'instance sur le même hôte physique. Pour migrer vers un nouveau matériel, vous devez arrêter et démarrer l'instance.

Résolution

Tout d'abord, consultez les métriques de surveillance de l'état de l'instance pour identifier la surveillance d'état qui a échoué. Prenez ensuite les mesures suivantes en fonction de la vérification d'état qui a échoué.

Configurer votre instance pour un arrêt et un démarrage

Remarque : lorsque vous arrêtez et démarrez une instance, son adresse IP publique change. Une bonne pratique consiste à utiliser une adresse IP Elastic pour acheminer le trafic externe vers votre instance au lieu d'une adresse IP publique. Si vous utilisez Amazon Route 53, vous devrez peut-être mettre à jour les enregistrements DNS Route 53 lorsque l'adresse IP publique change. Un arrêt et un démarrage sont différents d'un redémarrage d'instance. Pour plus d'informations, consultez la section Fonctionnement de l'arrêt et du démarrage d'une instance EC2.

Avant d'arrêter et de démarrer votre instance, effectuez les actions suivantes :

Résoudre les problèmes de contrôle de l'état du système

Les échecs de contrôle de l'état du système se produisent en cas de problèmes liés à l'infrastructure sous-jacente sur laquelle votre instance s'exécute.

Pour résoudre les problèmes de contrôle de l'état du système, consultez le tableau de bord AWS Health pour détecter les interruptions de service dans la région AWS où se trouve votre instance.

En l’absence de panne, cela signifie qu'il existe un problème au niveau de l'hôte sous-jacent de l'instance. Pour résoudre ce problème, procédez comme suit pour migrer l'instance vers un nouvel hôte sous-jacent :

  1. Arrêtez l’instance.
    Remarque : si votre instance est bloquée à l'état Stopping (Arrêt), forcez l'arrêt de l'instance. Cette action peut prendre jusqu'à 10 minutes.
  2. Démarrez l'instance.

Pour récupérer automatiquement les instances qui échouent aux contrôles de l'état du système, configurez la récupération automatique des instances.

Important : un arrêt forcé ne vide pas les caches du système de fichiers et peut entraîner une perte ou une corruption de données. Après un redémarrage, exécutez les commandes suivantes en fonction de votre système d'exploitation (OS) pour vérifier l'absence d'erreurs de cohérence dans le système de fichiers.

Linux :

fsck

Windows :

chkdsk
sfc /scannow	

La commande chkdsk vérifie le système de fichiers et les métadonnées du système de fichiers du volume pour détecter les erreurs logiques et physiques. La commande sfc/scannow vérifie que les systèmes de fichiers ne sont pas corrompus. Pour plus d'informations, consultez chkdsk et Utilisation du Vérificateur des fichiers système sur le site Web de Microsoft.

Résoudre les échecs de surveillance de l'état de l’instance

Les surveillances de l'état de l'instance permettent d'identifier les problèmes liés au système d'exploitation, à la configuration réseau et à l'utilisation des ressources. Pour résoudre les échecs de surveillance de l'état de l'instance, utilisez les ressources suivantes en fonction du système d'exploitation de votre instance :

Résoudre les échecs de vérification d'état de l'EBS attaché

Si votre instance échoue à la vérification d'état de l'EBS attaché, vérifiez la métrique VolumeStalledioCheck dans Amazon CloudWatch pour le volume concerné. Si la valeur est 1, cela signifie que le volume présente des problèmes. En règle générale, Amazon EBS diagnostique et restaure automatiquement le volume en quelques minutes. Pour plus d'informations, consultez Caractéristiques et surveillance des E/S Amazon EBS.

Pour vérifier que le volume a été restauré, vérifiez si VolumeStalledioCheck prend la valeur 0.

Si le problème persiste, arrêtez et démarrez l'instance pour la migrer vers un nouvel hôte. Si un volume spécifique présente toujours des problèmes après le redémarrage, vous devez le remplacer. Créez un instantané du volume, puis créez un nouveau volume à partir de cet instantané. Utilisez le nouveau volume pour remplacer le volume existant.

Informations connexes

Résoudre les problèmes liés à une instance Amazon EC2 inaccessible

AWS OFFICIELA mis à jour il y a 6 mois