Passer au contenu

Comment puis-je résoudre l’erreur de journal « RequestError: send request failed caused by: » de SSM Agent ?

Lecture de 3 minute(s)
0

Je souhaite résoudre un message d’erreur « RequestError: send request failed caused by: Post https://ssm.RegionID.amazonaws.com/: dial tcp IP:443: i/o timeout » que je trouve dans mes journaux d’AWS Systems Manager Agent (SSM Agent).

Brève description

Les erreurs « RequestError: send request failed by : » indiquent que Systems Manager n'a pas enregistré votre instance Amazon Elastic Compute Cloud (Amazon EC2) en tant qu'instance gérée.

Les problèmes suivants peuvent empêcher l'enregistrement de votre instance :

  • AWS Systems Manager utilise un point de terminaison de VPC d’interface dans Amazon Virtual Private Cloud (Amazon VPC) et l'instance utilise un serveur DNS personnalisé dans un sous-réseau privé.
  • L'instance se trouve dans un sous-réseau privé et n'a pas accès aux points de terminaison de Systems Manager ni à Internet.
  • Votre instance se trouve dans un sous-réseau public qui n'autorise pas les connexions sortantes aux points de terminaison de Systems Manager sur le port 443.
  • SSM Agent ne peut pas se connecter au serveur de métadonnées de votre instance qui se trouve derrière un proxy HTTP.

Résolution

Utilisez les chemins d’emplacement suivants pour vérifier que l'un de vos journaux contient le message d'erreur :

  • Pour Linux et macOS :
    /var/log/amazon/ssm/amazon-ssm-agent.log
    /var/log/amazon/ssm/errors.log
  • Pour Windows :
    %PROGRAMDATA%\Amazon\SSM\Logs\amazon-ssm-agent.log
    %PROGRAMDATA%\Amazon\SSM\Logs\errors.log

Si l'un de vos journaux contient l'erreur, effectuez les étapes de résolution suivantes.

Résoudre les problèmes liés aux instances de sous-réseaux privés qui utilisent des points de terminaison de VPC Systems Manager et un serveur DNS personnalisé

Les points de terminaison de VPC prennent en charge uniquement le serveur Amazon DNS qui utilise Amazon Route 53 Resolver. Utilisez Route 53 Resolver pour résoudre les requêtes DNS entre le VPC et votre réseau.

Pour transférer une requête concernant le domaine amazonaws.com vers le résolveur DNS VPC par défaut, utilisez le redirecteur conditionnel de votre serveur DNS personnalisé.

Résoudre les problèmes liés aux instances d'un sous-réseau public qui ne peuvent pas se connecter aux points de terminaison de Systems Manager ou à Internet

Utilisez le dossier d'exploitation AWSSupport-TroubleshootManagedInstance, l'interface de la ligne de commande AWS (AWS CLI) ou des étapes de résolution de problèmes manuelles pour résoudre les problèmes de connectivité de votre instance. Pour en savoir plus, consultez la section Pourquoi Systems Manager n'affiche-t-il pas mon instance Amazon EC2 en tant qu'instance gérée ?

Résoudre les problèmes liés aux instances d'un sous-réseau public qui n'autorisent pas les connexions sortantes sur le port 443

Configurez les règles de groupe de sécurité d’Amazon VPC et les listes de contrôle d'accès au réseau (ACL réseau) pour autoriser les connexions sortantes vers les points de terminaison Systems Manager sur le port 443.

Résoudre les problèmes liés aux instances qui utilisent un proxy

Configurez SSM Agent afin qu'il fonctionne avec un proxy et définissez no_proxy pour l'URL des métadonnées. Pour des instructions, consultez la documentation AWS suivante :

Informations connexes

Comprendre Amazon DNS

Création de points de terminaison de VPC pour Systems Manager

Ensembles d'options DHCP dans Amazon VPC

AWS OFFICIELA mis à jour il y a 7 mois