AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
Come posso risolvere gli errori di eccezione SQL con origini dati SQL personalizzate in Quick Suite?
Ho provato a utilizzare origini dati SQL personalizzate in Amazon Quick Suite, ma ricevo il messaggio di errore "Your database generated a SQL exception".
Breve descrizione
Quando Quick Suite esegue query su un'origine dati SQL o la aggiorna, ricevi il seguente messaggio di errore:
"Your database generated a SQL exception. This can be caused by query timeouts, resource constraints, unexpected DDL alterations before or during a query, and other database errors. Check your database settings and your query, and try again."
Potresti ricevere il messaggio di errore precedente per i seguenti motivi:
- La query scade.
- È presente un problema di connessione del cloud privato virtuale (VPC) all'origine dati.
- L'account Quick Suite non ha l'autorizzazione necessaria per accedere ai dati.
- Il ruolo di servizio per Quick Suite non è autorizzato ad accedere alla chiave del Servizio AWS di gestione delle chiavi (AWS KMS).
- Hai utilizzato tipi di dati o funzioni non supportati.
Nota: per ulteriori informazioni sulla causa dell'errore, scegli Mostra dettagli sotto il messaggio di errore.
Se ricevi il messaggio di errore precedente durante l'aggiornamento del set di dati, i dettagli dell'errore sono disponibili alla voce Riepilogo del set di dati. Scegli Status Import Failed (Stato Importazione non riuscita) per maggiori informazioni.
Se nella dashboard viene visualizzato il messaggio di errore precedente, passa ad Underlying analysis (Analisi sottostante) e scegli Concerned visual(s) (Immagini interessate). Osserva il set di dati che si trova nel pannello sinistro dell'analisi, quindi visualizza la voce Riepilogo del set di dati.
Risoluzione
Nota: se ricevi errori quando esegui i comandi dell'Interfaccia della linea di comando AWS (AWS CLI), consulta Risoluzione degli errori per AWS CLI. Inoltre, assicurati di utilizzare la versione più recente di AWS CLI.
La query scade
Se la query SQL personalizzata scade, semplificala per ottimizzare il runtime. Per altre soluzioni al timeout delle query, consulta Come posso risolvere gli errori di timeout della query in Quick Suite?
È presente un problema di connessione del VPC all'origine dati
Ricevi uno dei seguenti messaggi di errore:
"Communications link failure The last packet successfully received from the server was #### milliseconds ago. The last packet sent successfully to the server was #### milliseconds ago."
-oppure-
"Communications link failure The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server."
Se riscontri problemi riguardanti la connessione del VPC alle origini dati, controlla il gruppo di sicurezza di rete del VPC associato alla risorsa. Per ulteriori informazioni, consulta Configurazione delle connessioni VPC in Amazon Quick Suite.
L'account Quick Suite non ha l'autorizzazione necessaria per accedere ai dati
Se ricevi un errore di eccezione SQL quando tenti di accedere ai dati in un servizio AWS, controlla l'accesso di Quick Suite ai servizi AWS.
Completa i seguenti passaggi:
- Apri la console Quick Suite.
- Scegli il tuo nome utente nella barra delle applicazioni, quindi seleziona Manage Quick Suite (Gestisci Quick Suite).
- Nel pannello di navigazione, in Autorizzazioni, scegli Risorse AWS.
- Configura l'accesso alle origini dati supportate.
Se utilizzi AWS Organizations, ricevi l'errore quando non ti vengono assegnate le policy di controllo dei servizi (SCP) necessarie. È consigliabile chiedere all'amministratore dell'organizzazione di controllare le autorizzazioni assegnate all'utente nelle impostazioni delle SCP.
Se sei un amministratore di Organizations, consulta Aggiornare una policy di controllo del servizio (SCP).
Il ruolo di servizio per Quick Suite non è autorizzato ad accedere alla chiave AWS KMS
Ricevi il seguente errore:
"If you are encrypting query results with KMS key, please ensure you are allowed to access your KMS key."
Per verificare che il ruolo di servizio per Quick Suite abbia le autorizzazioni per la chiave AWS KMS corrette, completa i seguenti passaggi:
- Utilizza la console AWS Identity and Access Management (AWS IAM) per individuare l'ARN del ruolo di servizio per Quick Suite.
- Utilizza la console Amazon Simple Storage Service (Amazon S3) per trovare l'ARN della chiave AWS KMS. Vai al bucket contenente il file di dati. Scegli la scheda Panoramica, quindi individua l'ID della chiave AWS KMS.
- Esegui il comando AWS CLI create-grant per aggiungere l'ARN del ruolo di servizio per Quick Suite alla policy della chiave AWS KMS:
Nota: sostituisci aws_kms_key_arn con l'ARN della chiave AWS KMS e quicksight_role_arn con l'ARN del ruolo di servizio per Quick Sight.aws kms create-grant --key-id aws_kms_key_arn --grantee-principal quicksight_role_arn --operations Decrypt
I tipi di dati o le funzioni in uso non sono supportati
Se cerchi di importare un tipo di dati non supportato o di utilizzare una funzione SQL non supportata, ricevi un errore di eccezione SQL. Per risolvere il problema, verifica l'origine dati SQL per determinare se il tipo di dati o la funzione SQL sono supportati.
Per vedere cosa è supportato, consulta le seguenti risorse:
- Tipi di dati supportati da origini dati esterne
- Valori e tipi di dati supportati
- Funzioni per categoria
Informazioni correlate
Quote per le query SQL dirette
How can I create a private connection from Amazon Quick Suite to an Amazon Redshift cluster or an Amazon RDS DB instance that's in a private subnet? (Come posso creare una connessione privata da Amazon Quick Suite a un cluster Amazon Redshift o a un'istanza database Amazon RDS che si trova in una sottorete privata?)
Azioni, risorse e chiavi di condizione per Amazon Quick Suite
- Argomenti
- Business Applications
- Lingua
- Italiano

Contenuto pertinente
AWS UFFICIALEAggiornata 10 mesi fa