AWS Macie not work with sensitive data


I tried setting the AWS Macie to analyze sensitive data. but not work. I create the following "custom data identifiers"

Name: Test01
Regular expression: (?i)batman\.txt.*
Keywords: None
Ignore words: None
Maximum match distance: 50
Occurrences threshold: 1
Severity Level: Medium

Create the job.

I analysing the session file of the SSM. I connect to the server EC2 via session manager and run the command "scp batman.txt server:~" for example. Is it possible to get this?

The bucket s3

But not work. Let me know if i'm doing something wrong.

  • Hi ricardobarbosams - would you able to include an excerpt of a few lines of context in the relevant log file that contains "scp batman.txt server:~" or similar? You can obfuscate things like your servername or any user names, as long as the format is preserved. Thanks!

4 Risposte

Hi, Chris, thanks for replying

of course, follow

]0;root@ip-172-30-102-209: ~root@ip-172-30-102-209:~# scp batman.txt server01:~
ssh: Could not resolve hostname server01: Temporary failure in name resolution

lost connection

]0;root@ip-172-30-102-209: ~root@ip-172-30-102-209:~# scp batman.txt server01:~:~:~:~:~:~:~:~:~:~ :~1:~2:~7:~.:~0:~.:~0:~.:~1:~

The authenticity of host ' (' can't be established.

Are you sure you want to continue connecting (yes/no/[fingerprint])? yes

Warning: Permanently added '' (ECDSA) to the list of known hosts.

root@ Permission denied (publickey).

lost connection

]0;root@ip-172-30-102-209: ~root@ip-172-30-102-209:~# scp batman.txt

root@ Permission denied (publickey).

lost connection

]0;root@ip-172-30-102-209: ~root@ip-172-30-102-209:~# exit
con risposta 2 anni fa

Thank you for the context, this is very helpful.

On first investigation it appears that the issue is not with the custom detection, but rather the format of the log file. Using the excerpt you provided above, I ran this through Macie and the file was not scanned due to an UNSUPPORTED_FILE_TYPE_EXCEPTION. This is visible in the discovery results that are published to your S3 bucket.

The team is having a look to see if this is something that's easily addressable.

con risposta 2 anni fa

Thanks for replying Cris :)

con risposta 2 anni fa

I tested by creating a file with string scp batman server:~ and it worked.

con risposta 2 anni fa

Accesso non effettuato. Accedi per postare una risposta.

Una buona risposta soddisfa chiaramente la domanda, fornisce un feedback costruttivo e incoraggia la crescita professionale del richiedente.

Linee guida per rispondere alle domande