amazonlinux2023にphp8.3のインストールしたいです。

0

amazonlinux2023に対してphp8.3のインストールしたいです。 php8.1にて運用していましたが、php8.3へ移行したいです。

taka
質問済み 4ヶ月前1686ビュー
1回答
0

以下のドキュメントを見る限り現状はPHP8.2までしかデフォルトのリポジトリだとインストールできないのでソースからインストールみたいな作業が必要になると思います。
作業として楽なのはPHP8.2を入れることだと思います。
https://docs.aws.amazon.com/linux/al2023/ug/php.html

PHPのライブラリは"./configure"を実行する際にオプションで設定してください。
以下のブログなどが参考になると思います。
https://zenn.dev/team_delta/articles/e755f34f50af4c
https://blog.future.ad.jp/centos7%E3%81%ABphp8%E3%82%92%E3%82%BD%E3%83%BC%E3%82%B9%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E3%81%97%E3%81%A6%E3%81%BF%E3%81%9F

一応以下のコマンドで最低限PHP8.3をインストールできることを確認しました。

sudo su -
dnf install gcc libxml2-devel sqlite-devel -y
wget https://www.php.net/distributions/php-8.3.0.tar.gz
tar -xzvf php-8.3.0.tar.gz
cd php-8.3.0/
./configure
make
make install
profile picture
エキスパート
回答済み 4ヶ月前

ログインしていません。 ログイン 回答を投稿する。

優れた回答とは、質問に明確に答え、建設的なフィードバックを提供し、質問者の専門分野におけるスキルの向上を促すものです。

質問に答えるためのガイドライン