Can not connect to mariadb after creating a new instance from a linux Lightsail snapshot


It was just last week this was working just fine, I was able to create a new instance from a lightsail snapshot (linux) and everything worked well. But today when I try to create another instance from a newer snapshot, I couldn't connect to mariab, here is the error message:

ERROR 2002 (HY000): Can't connect to server on '' (115)

I am trying to connect to the database using this command:

mysql -h  -u root -p <redacted>

I tried some solutions I found on google but still can not make it work, can anyone help help to provide some insights? Thank you!

  • Hi, I updated your question to redact some information that would be best to not share publicly.

質問済み 3ヶ月前186ビュー

Is MariaDB running locally on the Linux host? There should be output showing that it's listening on the default port sudo netstat -tulpn | grep -w 3306

It would also be worth double-checking the syntax of the mysql command, according to the MariaDB Command-Line Client page

-p, --password[=name]

Password to use when connecting to server. If you use the short option form (-p), you cannot have a space between the option and the password

profile picture
回答済み 3ヶ月前

ログインしていません。 ログイン 回答を投稿する。