내용으로 건너뛰기

Systems Manager에서 빠른 설정 패치 정책 오류를 해결하려면 어떻게 해야 합니까?

2분 분량
0

AWS Systems Manager의 기능인 빠른 설정을 사용하여 Amazon Elastic Compute Cloud(Amazon EC2) 인스턴스 패치를 적용할 때 발생하는 오류를 해결하고 싶습니다.

간략한 설명

Amazon EC2 인스턴스를 업데이트하기 위해 빠른 설정을 사용하여 패치 정책을 생성할 때 다음 예시와 유사한 오류 메시지가 나타날 수 있습니다.

  • Linux 인스턴스의 경우:
    "Unable to download file from S3: s3://aws-quicksetup-patchpolicy-543312345141-12345/baseline_overrides.json. botocore.exceptions.ClientError: An error occurred (403) when calling the HeadObject operation: Forbidden No IMDS credentials found on instance.failed to run commands: exit status 156"
  • Windows 인스턴스의 경우:
    "Invoke-PatchBaselineOperation: User: arn:aws:sts::543312345141:assumed-role//i-12345678911223344 is not authorized to perform: s3:GetObject on resource: "arn:aws:s3:::aws-quicksetup-patchpolicy- 543312345141-12345/baseline_overrides.json" with an explicit deny in a resource-based policy"
    참고: 이 메시지는 패치 작업의 Error(오류) 섹션에 표시됩니다.

이전 오류는 Amazon EC2 인스턴스에 Amazon Simple Storage Service(Amazon S3) 버킷에서 패치 구성 파일을 다운로드할 수 있는 권한이 없음을 나타냅니다.Systems Manager는 패치 구성 파일을 사용하여 적용할 패치와 인스턴스 간의 패치 작업 관리 방법을 결정합니다.

이 오류를 해결하려면 S3 버킷에서 패치 기준 구성 파일을 다운로드하는 데 필요한 권한을 추가하십시오. 그런 다음 AWS Systems Manager의 기능인 State Manager에 대한 올바른 연결을 적용했는지 확인하십시오.

해결 방법

패치 기준 구성 파일 다운로드 권한 추가

AWS Systems Manager의 기능인 빠른 설정은 Systems Manager에서 패치 정책을 생성할 때 패치 기준 구성 파일이 포함된 버킷을 생성합니다. 버킷 이름은 aws-quicksetup-patchpolicy-example-quick-setup-configuration-id와 유사합니다.

인스턴스가 버킷에 액세스하는 데 필요한 권한을 추가하십시오. 지침은 패치 정책 S3 버킷에 대한 권한을 참조하십시오.

빠른 설정이 인스턴스에 적용한 연결 검토

State Manager 연결 기록을 보고 다음 연결을 확인하십시오.

  • Amazon EC2 인스턴스의 경우:

    AWS-QuickSetup-PatchPolicy-AttachIAMToEc2Instance-example-quick-setup-configuration-id
  • 하이브리드 인스턴스의 경우:

    AWS-QuickSetup-PatchPolicy-AttachIAMToHybridInstance-example-quick-setup-configuration-id

연결 실행이 수행되지 않은 경우 Apply association now(지금 연결 적용) 버튼을 선택하여 인스턴스에 연결을 적용합니다. 그런 다음, 다음 State Manager 연결을 실행합니다.

AWS-QuickSetup-PatchPolicy-ScanForPatches-example-quick-setup-configuration-id

참고: example-quick-setup-configuration-id를 빠른 설정 구성의 ID 번호로 바꾸십시오.

정책이 성공하지 못하면 출력을 검토하여 실패 이유를 확인하십시오. 그런 다음 조사 결과를 바탕으로 AWS Systems Manager의 기능인 Patch Manager 문제를 해결하십시오.

AWS 공식업데이트됨 5달 전