Quero solucionar erros que ocorrem quando uso o Run Command, um recurso do AWS Systems Manager, para executar comandos na minha instância gerenciada do Amazon Elastic Compute Cloud (Amazon EC2).
Resolução
Pré-requisitos: Você deve configurar uma política de usuário do AWS Identity and Access Management (IAM) antes de usar o Run Command para gerenciar instâncias do EC2. A política do usuário é necessária para os usuários que executam comandos. Para verificar se você configurou as políticas necessárias, conclua as seguintes ações ou configure:
- Verifique se você anexou uma função de perfil de instância do IAM para o Systems Manager às suas instâncias. Para obter mais informações, consulte Configurar as permissões de instância necessárias para o Systems Manager.
- Verifique se o perfil ou a política do IAM do usuário tem permissões para usar as operações de API necessárias. Para obter mais informações sobre as operações de API que sua instância exige, consulte Operações de API relacionadas ao agente (ssmmessages e endpoints ec2messages).
Ou use a configuração de gerenciamento de host padrão. O Systems Manager gerencia automaticamente as instâncias sem um perfil de instância do IAM quando você ativa a configuração padrão de gerenciamento de host. A configuração padrão de gerenciamento de host está disponível no AWS Systems Manager Agent (SSM Agent) versão 3.2.582.0 ou posterior. Certifique-se de preencher os pré-requisitos necessários antes de ativar a configuração padrão de gerenciamento de host
Observação: Se você usar a configuração padrão de gerenciamento de host ativada, todas as instâncias associadas deverão usar o Instance Metadata Service Version 2 (IMDSv2).
Solucionar falhas de execução do comando
No console do Systems Manager, em Fleet Manager, a instância deve aparecer como uma instância gerenciada e o status de ping do SSM Agent deve ser Online. Se a opção Executar comando falhar, conclua as seguintes ações:
Examinar os detalhes do status do Run Command
Conclua as etapas a seguir:
- Examinar os detalhes do status do Run Command.
- Abra o console do Systems Manager.
- No painel de navegação, selecione Run Command.
- (Opcional) para verificar um Run Command que você usado anteriormente, escolha a guia Histórico de comandos.
- Escolha a ID do comando que corresponde ao seu comando para abrir a página de Status do comando.
- Na seção Destinos e saídas, escolha o ID da instância que corresponde à sua instância e, em seguida, revise a saída.
Se a saída estiver truncada, use SSH to e navegue até os seguintes diretórios para ver os detalhes completos do erro:
Importante: Alguns plug-ins são executados somente em instâncias do Windows Server ou Linux. Para obter uma lista de plug-ins que você pode especificar em um documento de comando e as dependências da plataforma de cada plug-in, consulte Referência do plug-in do documento de comando.
Para Linux e macOS:
- /var/lib/amazon/ssm/example-instance-ID/document/orchestration/example-command-id/example-plugin-name/example-step-name/stdout
- /var/lib/amazon/ssm/example-instance-ID/document/orchestration/example-command-id/example-plugin-name/example-step-name/stderr
Para Windows:
- %ProgramData%\Amazon\SSM\InstanceData\example-instance-ID\document\orchestration\example-command-id\example-plugin-name\example-step-name\stdout
- %ProgramData%\Amazon\SSM\InstanceData\example-instance-ID\document\orchestration\example-command-id\example-plugin-name\example-step-name\stderr\
Observação: Substitua example-instance-ID pelo número do ID de sua instância. Substitua example-command-ID pelo seu ID de comando. Substitua example-command-ID pelo nome do plug-in que especificado no documento de comando. Substitua example-step-name pelo valor do nome que corresponde ao plug-in que você especifica na seção mainSteps de seu documento de comando.
Revise os códigos de status de saída nos detalhes da saída e, em seguida, utilize esses códigos para solucionar problemas com o Run Command.
Revisar os logs do SSM Agent
Examine seus logs do SSM Agent para obter mais detalhes sobre a falha e, em seguida, use seus registros para solucionar os erros encontrados. Se os logs do Agente SSM não fornecerem as informações necessárias para resolver o erro, permita que o registro em log da depuração do Agente SSM reproduza o problema.
Importante: O painel do AWS Systems Manager CloudWatch não estará mais disponível após 30 de abril de 2026. Use o console do CloudWatch para visualizar, criar e gerenciar seus painéis doCloudWatch.
Informações relacionadas
Documentos do AWS Systems Manager
Configuração do AWS Systems Manager