EKS - aws-ebs-csi-driver add-on advanced configuration problem arisen suddenly

0

Hi, I am using the aws-ebs-csi-driver add-on, and while it used to work so far, suddenly I noticed that this plugin was in degraded state (without me doing anything), then I could not upgrade its version, until I removed this configuration, and now I cannot add it back. I get the below error when I try to input advanced configuration below:

UnsupportedAddonModification Amazon EKS was unable to complete the addon operation. The configuration values provided are invalid.

Here is my JSON:

{
	"controller": {
		"nodeSelector": {
			"kubernetes.io/os": "linux",
			"aaaaa": "xxx-yyy-zzz",
			"some_other_key": "abcd"
		}
	}
}

which seems valid, according to the schema I get from

aws eks describe-addon-configuration --addon-name aws-ebs-csi-driver --addon-version v1.17.0-eksbuild.1 

I also tried without whitespace, but same result. Also tried in YAML format, nothing, same error.

Has something changed? Some new bug? It doesn't make sense really.

babis
asked a year ago526 views
1 Answer
1

The above is due to the fact that "kubernetes.io/os": "linux" is included the node selector. This key/value is already hardcoded into the node selector used in the add-on. If you remove "kubernetes.io/os": "linux", it should work fine, and they will still get that node selector since it's built into the add-on anyways.

answered a year ago
  • This has worked, thank you for letting me know about this. I think it's a bit strange, although I get why this would need to happen. The error message could be more descriptive so it's easier to spot those small things. Would be good to document this note too (if not already and just missed it). Thanks again!

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions