How do i fix ec2:DescribeFpgaImages error in aws cli?

0

To check AMI and AFI approved by others using AWS cli, I used the command "aws ec2 description-fpga-images > output",

An error occurred (UnauthorizedOperation) when calling the DescribeFpgaImages operation: You are not authorized to perform this operation. User: arn:aws:iam::"user-id":user/"name" is not authorized to perform: ec2:DescribeFpgaImages because no identity-based policy allows the ec2:DescribeFpgaImages action

The error phrase appears. How do i solve this? I tried to solve the error by adding a policy, but no policy fits it.

Key setting and regional setting were carried out without any problems in advance.

1 Answer
0

Hello!

Thank you for reaching out with this issue. I have a few questions that may lead to debug paths or for us to reproduce this issue:

  1. Which AWS region are you attempting to run this command on?
  2. Have you tried running this command in an AWS CloudShell?
  3. Were you able to run the CLI command with the same user and role before?
  4. Which IAM policies did you attempt to add before running the command? We recommend trying AdministratorAccess to debug the issue
answered 2 months ago
profile picture
EXPERT
reviewed 22 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions