With a Security group I can't connect to EC2 instance


Hello, I have a security group which allows inbound traffic to port 22 from the world, then I created an EC2 instance with that security group attached but I can't connect to the instance, the instance of course has an external public IP (AWS assigned one inside 3.24x.x.x range) but I cant' connect, this instance is in eu-west-1 (Ireland), I don't even get a response using telnet on port 22 while trying to connect to it, however, if I create an EC2 instance with the same SG rules (different SG because it's different region but the same rules) in eu-west-3 (Paris) I can connect. I tried this many times with the same result, thank you for any help

asked 2 years ago2379 views
1 Answer
Accepted Answer


The Security groups are just one of the factors needed to enable access. There are multiple other parameters like NACL's, Public IP, Routing etc that need to be verified between the 2 environments before reaching to a conclusion. Have you checked the routing that is set ?

Assuming, you are trying to access the same from On-Premise over the internet, did you verify if Internet gateway is attached to the routing in the EC2 instance. Please verify the same or provide more information on how is the routing set up.

Link- https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/TroubleshootingInstancesConnecting.html

profile pictureAWS
answered 2 years ago
profile pictureAWS
reviewed 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions