Lightsail Port forwarding


I've written a Windows .exe file which listens using Windows sockets for client connections on port 4897, in order to forward TCP packets between mobile phones to play one of my networked games. It works fine on my Windows laptop, but I have to configure my router to forward the packets on from the router to that specific laptop.

I wanted to set the .exe file up on a Windows virtual Lightsail instance instead. I have it up and running, I've set up a static IP address, and I went to to the Networking | Firewall settings and added a rule to allow TCP packets on port 4897. But mobile phones don't seem to be able to connect to the .exe file still. I'm not sure what I'm doing wrong?

1 Answer
Accepted Answer

All I needed to do was go into Windows Defender Firewall and select Advanced Settings | Inbound Rules | New Rule | Port and added the port number there

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions