My domain record in Route 53 that points to an Amazon S3 bucket or static website is not resolving


Fllowing the following tutorial:

I registered a domain using AWS, my domain is After that, I created an S3 bucket( static website and another bucket for the subdomain(

S3 bucket works fine with url:

Then I created a hosted zone for both S3:

Record name Type Routing policy Differentiator Value/Route traffic to A Simple - NS Simple - A Simple -

When I try to go to the site(,,,, result is:

This site can’t be reached Check if there is a typo in DNS_PROBE_FINISHED_NXDOMAIN

I deleted my browser cache and tried 3 different browsers (edge, safari, chrome) with the same result.

2 Answers

I assume that you have created a public hosted zone on Route 53. You need to create an alias record that points to your S3 bucket . Summary of the required actions:

  • Enter the domain name that you want to use to route traffic to your S3 bucket. The default value is the name of the hosted zone.

  • Choose Alias to S3 website endpoint, then choose the Region that the endpoint is from.

  • Choose the bucket that has the same name that you specified for Record name. The list includes a bucket only if the bucket meets the following requirements:

      The name of the bucket is the same as the name of the record that you're creating.
      The bucket is configured as a website endpoint.
      The bucket was created by the current AWS account.
  • Record type : Choose A – IPv4 address.

  • Evaluate target health

Can you confirm you did all these steps?

answered 3 months ago
  • I have the same issue and I have tried this solution and I am still with no luck. I have 2 other sites that are working as expected and I'm not able to get the 3rd site running. I have followed many solutions and still no luck. What could it be??

  • i too have the same issue. the s3 bucket website endpoint link is not showingup in the dropdown list to add. tried many ways. still no luck. any solutions ??

  • I have done these steps and it still is resulting in the same error for me


Were you able to find a solution to this problem? I am experiencing the same issue and have not found a solution yet. Thank you!

answered a month ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions