Bedrock is not processing KB results correctly

1

I want to identify why the Bedrock Agent and KB test KB queries are not behaving as expected and fix the problem. We believe something has changed in AWS and not our KB or agent.

Monday, February 19, 2024, we noticed that our agents on Bedrock were not working as expected. It appears that the agent is only getting 0 or 1 chunk from the KB. I have logged the SQL statements on the KB database, and the top record best matches the query. However, the KB test indicates zero results were found in the KB. Last week the agent and KB test was able to get multiple results from the KB. I have logs from last week having multiple chunks returned from KB queries. It will get at most one chunk when I perform the same prompt today.
We have tried creating different kinds of KB and are getting the same results. We have tried rebuilding the KB and same results.

AWS posted a change on the 19th https://aws.amazon.com/about-aws/whats-new/2024/02/amazon-documentdb-vector-search-hnsw-index/ I don't know if this is related but it does hint that something changed.

I have a prompt that when used in the KB test it will find zero chunks. If I take the logged SQL statement from the KB's query and run it manually I see that I get 5 records and the top record is the expected match.

  • It appears Bedrock is selecting the 5th chunk returned as the 1 chunk. I don't think there is anything wrong with the KB database.

  • It appears the issue has been resolved. Bedrock is returning multiple KB chunks from an RDS-backed vector store.

asked 2 months ago196 views
1 Answer
0

I believe AWS has fixed the issue.

answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions