Why is there a recommended version for MSK

4

If you look at the supported version of MSK (https://docs.aws.amazon.com/msk/latest/developerguide/supported-kafka-versions.html) you'll notice that there is a supported version (currently 2.6.2).

Anyone an idea why? What's the drawback with other/newer versions? Less tested? Less stable? ...?

Tom
asked 2 years ago2250 views
1 Answer
2

We have a few guiding tenets around what versions we recommend. The first is only recommending bug fix releases as they will be more stable than major releases. We currently recommend 2.6.2, but we are also evaluating a revision of the recommended version. Second, we also track Kafka bugs in versions and based on the impact this will affect what version we recommend. We always recommend that customers run POC to test a Kafka version before moving to production.

AWS
SUPPORT ENGINEER
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions