Problem with root ebs volume (set up for 3TB ssd) for MS SQL (in window server) can not use more than 2TB

0

Description of problem: ec2 instance with 3x volumes are used for MS SQL server (in window server): **

One root volume is set up for 3 terabyte in aws, but actually 952 GB is not assigend (only 2.047TB is usable in some reasons). **

Symptom: In aws console, apprered to be all fine, but in window server showed the loss of space. Other two volumes are fine and I tried to refresh and increased one byte to re-optimise the storage, but still the same problem.

It would be grateulf if anyone can suggest. Many thanks.

wookee

Min
asked 7 months ago776 views
1 Answer
1

Is the volume in MBR format? This only supports up to 2TB, for anything more the disk format needs to be GPT.

See this question & answer on the Microsoft website, which seems to deal with a physical device rather than a cloud instance, but the underlying explanation is the same https://answers.microsoft.com/en-us/windows/forum/all/disk-partition-limit-of-2tb-in-windows-10-64-bit/3f8df997-6638-489f-a3cd-e12b0625deec

Much more detail is here https://learn.microsoft.com/en-us/troubleshoot/windows-server/backup-and-storage/support-for-hard-disks-exceeding-2-tb

profile picture
EXPERT
Steve_M
answered 7 months ago
profile pictureAWS
EXPERT
Rob_H
reviewed 7 months ago
  • To add to this it's typically not recommended to setup SQL server on the root volume of the OS, instead it's better to partition out the usage to several different disks with the needed performance specification for those disks.

  • Thanks, To fix this, which senario would be the best? <S1> Copy all existing root ebs volume to a new one which can be bigger than 2TB (because it is not root volume), then delete the root volume and use only other newly created volume. and add more volume as needed in the future. <S2> Reinstall SQL in a new ebs volume and attach necessary database resources (or copy) into the same volume or the separate volumes. I also thank Rob_H's comments. Could you elaborate bit? Cheers

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions