How do I resolve "mount point does not exist" error



I need to mount my EFS file system to my EC2 instance. The EFS instance and EC2 are in the same region. The DNS is enabled. I have tried to perform the mount in the EC2 command line interface (CLI) using the most common mounting strategies to perform the mount including attempting to to perform the mount using the EFS IP address, using the EFS file system ID, as well as the other mounting approaches. However, I still get the same error. I have verified my mount point exists, my EFS exists, and my EC2 instance exists. Below in the screenshot, you see me using the CLI to perform the most common approach to perform the mount by copying the "sudo mount" CLI command and pasting it in the CLI and you see it fails. I don't think I am doing anything wrong.

Thank you for helping

CLI command

mount error message

2 Answers

The mount point is where in Linux your mounting the efs into.

Create a folder on root.

sudo mkdir /efs

Then run your mount command again but change it to /efs at the end instead of efs

profile picture
answered 3 months ago
profile picture
reviewed 3 months ago
  • Hi Gary. Thanks for helping. I did create a folder in the CLI before attempting to mount and still got the same error.

  • Hey Ryder, You have to specify exactly where the folder is. Have you used the full path?

  • Hi Gary. I have included the full path of where my EFS folder resides where I want to create the mount and I get the same error saying the mount point does not exist. See attached screenshot

    Entering full path

  • Thanks for the screen shot however you haven’t specified the full path. It’s still the relevant path. You are in the ec2-users home directory currently and it’s looking for a directory in there called home.

    Please try /home/ec2-user/efs

    To confirm you have a efs directory in that location?

  • Hi Gary,

    I verified I am within the following correct directory which is the same one you instructed me to verify: /home/ec2-user/efs

    Please see attached screenshot

    Enter image description here


Hello Ryder,

you are missing "/" in the beginning of the mount point. what you were doing was

sudo mount -t ofs -o tls fs-040ab91881f87e80b:/ home/ec2-user/efs

Instead you needs to use:

sudo mount -t ofs -o tls fs-040ab91881f87e80b:/ /home/ec2-user/efs

Hope this helps.

answered 3 months ago
  • Hey Sheelnidhi, I am helping Ryder and I have said the exacat same. Its not for me. The / is missing from the mount point 100%

  • Corrected !

  • Thanks Sheelnidhi

  • I just tried using the "/" characters in the beginning and it did not work. I checked in my EC2 and EFS consoles and verified there is NO EFS instance attached to my EC2 instance

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions