XRT ERROR : failed to load xclbin : input output error hello_world tutorial on AWS F1 / AMI 1.12.2

0

I encountered an error during the official tutorial. (https://github.com/aws/aws-fpga/blob/master/Vitis/README.md)

I followed the tutorial in

AWS F1(f1.2xlarge) instance / oregon

FPGA Developer AMI - 1.12.2-40257ab5-6688-4c95-97d1-e251a40fd1fc ( latest )

AMI version : 1.12.2

Xilinx version : 2021.2

I ran ( $ source vitis_setup.sh source vitis_runtime_setup.sh ) and checked Building the host application, Xilinx FPGA binary and AFI creation completes successfully.

But when i run the cmd below

$ ./hello_world vadd.awsxclbin

It gave the following error Enter image description here

result of xbutil validate Enter image description here

failed to find /opt/xilinx/das ...

Can you give me a solution for this situation?

asked 8 months ago261 views
3 Answers
1
Accepted Answer

I solved this problem my self. I moved the region of f1 server from Oregan(us-west-2) to Virginia(us-east-1) and used s3 bucket (us-east-1a Virginia). After that i follwed procedure exactly when i tried before.

result

I suspect there's something problem with Oregon server

answered 7 months ago
0

I believe xbutil validate tries to run a 'hello world' test utilizing a .xclbin rather than the .awsxclbin that is needed for the F1 instances, and therefore cannot complete the test.

After you run vitis_runtime_setup.sh, do you get any error messaging? Try to run the following and see what they return:

xbutil examine -d 0000:00:1d.0

systemctl status mpd

Also could you show the dmesg log?

answered 8 months ago
  • Thanks you! I added some information below the comments!

0

There are only warning msgs when i run vitis_runtime_setup.sh. result of vitis_runtime_setup.sh

$ ./hello_world vadd.awsxclbin

Results after executing the above code.

xbutil examine -d 0000:00:1d.0

xbutil examine

systemctl status mpd

mpd status

and lastly the dmesg is here

[  229.765233] xocl 0000:00:1d.0:  ffff8a1f455d7098 _xocl_drvinst_open: OPEN 1
[  229.765253] xocl 0000:00:1d.0:  ffff8a1f455d7098 xocl_create_client: created KDS client for pid(2019), ret: 0
[  229.778556] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 icap_read_from_peer: reading from peer
[  229.778567] xocl 0000:00:1d.0: mailbox.u.9437184 ffff8a1f41e09c10 _mailbox_request: sending request: 10 via SW
[  229.778666] xocl 0000:00:1d.0: mailbox.u.9437184 ffff8a1f41e09c10 mailbox_read: Software TX msg is too big
[  229.792064] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 icap_cached_ocl_frequency: no cached data for 3
[  229.806554] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 icap_cached_ocl_frequency: no cached data for 3
[  229.809070] [drm] Finding MEM_TOPOLOGY section header
[  229.813663] [drm] Section MEM_TOPOLOGY details:
[  229.817717] [drm]   offset = 0x370
[  229.819410] [drm]   size = 0x120
[  229.822366] xocl 0000:00:1d.0:  ffff8a1f455d7098 xocl_preserve_mem: preserving mem_topology.
[  229.822386] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 __icap_download_bitstream_axlf: incoming xclbin: d7c3e394-c4b3-a533-73b7-fd82e16e3c27
on device xclbin: 00000000-0000-0000-0000-000000000000
[  229.822407] xocl 0000:00:1d.0: mailbox.u.9437184 ffff8a1f41e09c10 _mailbox_request: sending request: 8 via SW
[  229.822507] xocl 0000:00:1d.0: mailbox.u.9437184 ffff8a1f41e09c10 **mailbox_read: Software TX msg is too big**
[  230.673896] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 **__icap_peer_xclbin_download: peer xclbin download err: -5**
[  230.683249] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 icap_cache_bitstream_axlf_section: found kind 6(MEM_TOPOLOGY)
[  230.683257] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 icap_cache_bitstream_axlf_section: found kind 26(ASK_GROUP_TOPOLOGY)
[  230.683263] xocl 0000:00:1d.0: icap.u.23068672 ffff8a1f41e0b410 icap_download_bitstream_axlf: err: -5
[  230.683268] xocl 0000:00:1d.0:  ffff8a1f455d7098 xocl_read_axlf_helper: Failed to download xclbin, err: -5
[  230.697748] xocl 0000:00:1d.0:  ffff8a1f455d7098 xocl_destroy_client: client exits pid(2019)
[  230.697755] xocl 0000:00:1d.0:  ffff8a1f455d7098 xocl_drvinst_close: CLOSE 2
[  230.697759] xocl 0000:00:1d.0:  ffff8a1f455d7098 xocl_drvinst_close: NOTIFY ffff8a1f41e0cc10
answered 8 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions