adding s3 website endpoint as alias

0

cannot add s3 website endpoint as alias in hosted record creation. not getting the name of s3 website endpoint in pull down menu. tried diffrent regions. all direct links of s3 website endpoints works without any issue. there are two buckets in canada region, but nothing is listed in pulldown list. tried manually adding. added with an error. and nothing works

Enter image description here

Enter image description here

result in browser after manually adding the link

asked a year ago538 views
1 Answer
2
Accepted Answer

It is hard to tell since some of the key information is obfuscated, but I would say you can start by checking the name of the bucket in S3 matches the hostname in Route 53. If your site name is "my.example.com" then S3 required that the content be stored in a bucket called "my.example.com". It cannot be a bucket called "my" or "example.com" or any other name. It has to exactly match the hostname, and it must be lower case.

Also to support requests from both the root domain and subdomain, you must create two buckets. For example "my.example.com" and "www.my.example.com". You can view instructions on how to setup here.

AWS
debbie
answered a year ago
profile pictureAWS
EXPERT
reviewed a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions