Inserting new column not working using DMS

0

We are trying to do Data transfer by masking PII data from source RDS account to s3 bucket. But we are not able to add new column using add-column, we don't see any specific errors as well. we are able to remove existing column, but we are not able to add new column. Can anyone suggest what could be causing this issue and how can we resolve this? Below are mapping rules, which we are using: { "rules":[ { "rule-type": "selection", "rule-id": "1", "rule-name": "1", "object-locator": { "schema-name": "OWN", "table-name": "SCHOOL" }, "rule-action": "include", "filters":[] }, { "rule-type": "transformation", "rule-id": "2", "rule-name": "2", "rule-target": "column", "object-locator": { "schema-name": "OWN", "table-name": "SCHOOL" }, "rule-action": "add-column", "value": "DMS_EMAIL", "expression"; "'C'||SUBSTR(SEMAIL,6,2)", "data-type": { "type": "string", "length": 100 }, "old-value": null } ] }

1 Answer
0

Try the following:

-Set the transformation rule for the target column as "add-column" in the mapping rules JSON file. Specify the data type, length and expression to populate the column values. -When creating the DMS task, set the parameter "add_column_name" to true. This will include the column names in the migrated data. -The column values will be populated as per the expression defined in the transformation rule during the migration. -You can then load this data from S3 to another database or use it for other purposes.

Also: -Check that the RDS user has necessary privileges to add a column. -Make sure the column data type and length specified in the rule matches the target.

profile picture
EXPERT
answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions