Facing issues in rtmp push inputs

0

Hi,
I am creating two channels and I am creating separate inputs for both of them which are of type rtmp push inputs but the one input that is created first time for the channel is working but when I stream with separate channel and I create same type of settings and create an input of rtmp push it does not work it says video not detected and audio not detected.

asked 5 years ago553 views
5 Answers
0

himanshubhatt

Please private mail the MediaLive channel ARN of both the working and non-working channels and we can take a look at the issue.

In the meantime, things to check for:

  1. Validate the Input Security Group used in both channels.
  2. Validate that the upstream device sending RTMP to the MediaLive channels are configured with the correct destination IP addresses.
  3. Validate the RTMP AppName and AppInstance configured in your upstream RTMP device matches the AppName and AppInstance configured in the MediaLive Inputs.
answered 5 years ago
0

How to do a private email I don't know but same thing I am doing from the admin account it is working but not in other account. I am able to create the channel and create the inputs but when i start streaming it says input not found.

Edited by: fxeataws on Sep 10, 2019 8:37 AM

answered 5 years ago
0

himanshubhatt
The non-working channel has the RTMP AppName/AppInstance set to "a/b".
Additionally, the non-working channel is not receiving a/b, instead the source is publishing to the AppInstance "test2". This source will therefore be ignored, since it does not match the RTMP AppName/AppInstance in the channel configuration.

Please set your upstream RTMP source to send to the same RTMP AppName/AppInstance as defined in the MediaLive channel, or edit the MediaLive Input to match the RTMP AppName/AppInstance as defined in the upstream source.

answered 5 years ago
0

But I am pushing the rtmp through obs stream to .
rtmp://52.11.255.152:1935/a/b streamkey:test2
still it is not detecting
and test2 is the name of the input that we have to attach it asks for the id of the media input and then from the dropdown i select the media input id.

Edited by: himanshubhatt on Sep 10, 2019 9:15 AM

answered 5 years ago
0

Hi himanshubhatt,

You need to move the "b" from your address into the "streamkey" field.

In OBS, the Application Instance is called the Stream Key.

Regards,
Steve

AWS
Steve_W
answered 5 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions