i am using free tier as a new user. i am connecting my EC-2 instance from my laptop through putty.


i am unable to to connect my ec-2 instance. I am getting below error attached screen shot. I also tried with default user ec2-user but same error.Enter image description here

asked 2 years ago376 views
3 Answers
Accepted Answer

Hello, have you had a little at this article https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/putty.html ? it might help you out. check the ppk isn't just a rename but a conversion as well.

answered 2 years ago


Your problem can be related to incorrect login which varies depending on AMIs. Use following logins on following AMIs:

  • ubuntu or root on ubuntu AMIs
  • ec2-user on Amazon Linux AMI
  • centos on Centos AMI
  • debian or root on Debian AMIs
  • ec2-user or fedora on Fedora
  • ec2-user or root on: RHEL AMI, SUSE AMI, other ones.

If you are using OS:

  • Windows - get PEM key from AWS website and generate PPK file using PuttyGen. Then use Putty to use the PPK (select it using left-column: Connection->SSH->Auth: Private key for authorization)

  • Linux - run: ssh -i your-ssh-key.pem login@IP-or-DNS

refer- https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/putty.html

If the Answer is helpful, please click Accept Answer and up-vote, so that it can help others in the community looking for help on similar topics.

profile picture
answered 2 years ago

I was doing one terrible mistake. I deleted the original key pair and created the new one that was not accepted by the system. i created new instance and by its original key pair ssh that instance by the steps provided by you its connected. Thank you all for your support

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions