EC2 Windows doesn't


Hello! I have an issue with sound on Windows Server AMI. I have tried various instance types: t3.micro, g4dn.xlarge, g4dn.4xlarge etc, I have tried different Windows AMI: Microsoft Windows Server 2022 Base, Microsoft Windows Server 2019 Base, but each and every time i have no sound (input/output) devices (picture 1): Picture 1

I produced next steps:

  1. Run instance with Windows OS
  2. Connect via RDP
  3. Click on sound button in tray (picture 2): Picture 2
  4. Click "Yes" on dialog page (picture 3): Picture 3 But no matter what i have done Windows cannot detected any output/input devices: No output devices Nothing has helped: reboot, enabling via "services", installing Virtual Audio Cable etc. =( All services are enabled

Region: eu-north-1, example of EC2 instance config below: Instance config

Please, if you have any thoughts/ideas I would be really grateful) Thanks in advance))

2 Answers
Accepted Answer

NICE DCV on Windows may help. There is audio output and input support.

Refer to Installing the NICE DCV Server on Windows for manual installation instructions.

Or you can launch it from AWS Marketplace

Another option is to use the Windows Server CloudFormation template at amazon-ec2-nice-dcv-samples. It automates Windows setup and configuration. You can also specify the instance type (e.g. g4dn.xlarge) and graphics driver (e.g. NVIDIA gaming) to install.

For best experience, connect using NICE DCV client which can be downloaded from Screenshot of client below

Enter image description here

answered 10 months ago
  • Hi)) thanks for idea)) but again, i have custom streaming service, but If you have any ideas how to adjust Windows to "see" any output devices i would be really grateful)) Some how my friend with m2.medium and Windows 2019 have output device just "from the box", but on my instances I have no output devices and sound icon with red cross in trey (like on pictures)

    But on video tutorials they already have with sound: its really strange

  • I installed NICE DCV, but it doesnt help =(

  • Are you connecting via NICE DCV or RDP protocol? Open port 8443 TCP and UDP, and open browser to https://<Your-EC2-IP>:8443 or connect using NICE DCV client. In the video, he seems to be connected using NICE DCV client. Refer to updated post which include NICE DCV client screenshot.

  • Yeah, it works, still dont know will it be working, because i planned to use EC2 instance without any RDP/DCV etc. Just custom video and audio capture, but games doesnt recognize any audio devices, so my apps didn't work... But yeah, your solution allows to enable audio devices via DCV connection session. But still have to ask AWS for tech support. Anyway, THANK YOU SO MUCH for helping and your time)) you are a great person)) God bless you)


Hi, look is this similar question, where a solution was found for microphone:

profile pictureAWS
answered 10 months ago
  • Hi)) Thanks a lot for reply, but I dont need to hear sound via RDP. I'll use EC2 instances for streaming video, but there is no any output/input devices (as you can see on pictures). The post you have provided describes how to translate audio via RDP)

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions