aws cli commands hang on output


When I run a simple command like "aws help topics" the command hangs or terminates prematurely. On Windows, it outputs about 30 lines and terminates. On Debian Linux under Windows, it presents a black screen. If I then enter ctrl-z, it shows a few lines of output (like Windows) and terminates.

Here's the version info: aws-cli/2.4.7 Python/3.8.8 Windows/10 exe/AMD64 prompt/off aws-cli/2.4.10 Python/3.8.8 Linux/4.4.0-17763-Microsoft exe/x86_64.debian.11 prompt/off

I suspect that it involves the output paging mechanism. The first time that I ran it on debian, it complained of missing groff, so I installed that. I read about a problem when the less command is missing, but it isn't: the less command works.

1 Answer

Try adding to your profile in ~/.aws/config:

cli_pager =
profile pictureAWS
answered 2 years ago
  • Thanks for the suggestion, but it didn't help. Or change anything. I placed it in the default section. I also tried the --no-cli-pager switch on the command. No change.
    The command "aws help topics" should produce a lot of output, right? I get some about General, S3, and ddb, that's all.

  • That's exactly what I get. I think everything is working as designed. What are you looking for?

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions