SES - Server-side message: Network Failure


When I navigate to SES in US-EAST-1, I see the below message. It works in other regions. I used to use SES with this account, but haven't touched it in 6 months or so. What could be causing this? I even try with the root account and get the same thing, so I'm assuming it's not permission related. In Dev Tools I see net::ERR_CONNECTION_RESET, but again this is only for US-EAST-1.

Unknown error Request failed with unknown error, ensure that you have the necessary permissions and that all fields have correct values.

Server-side message: Network Failure

  • I also see the same issue..... all other regions work without issue.

  • this seems to be an issue across all accounts in virginia, looking at employers account and see the same... seems to be a much larger issue for the entire region.

  • I am having the same issue in us-east-1

  • I am having the same issue, Using AT&T internet with Active Armor security enabled which seems to be blocking the site. (I get notifications from my AT&T app) I have tried to add and exception for that URL, but so far it still doesn't work. Edit: It took a few hours, but it looks like the unblock action finally worked and I am able to use the site correctly again.

1 Answer

I had a similar problem recently. AWS Support told me that some customers connecting through a certain ISP are experiencing this issue. AWS Support's recommended solution is to go into your ISP router's firewall settings to allowlist the endpoint "". In my case, that was the URL that was generating error according to my dev tools. You may need to allowlist a different URL.

Alternatively, I solved this by connecting to the internet through a VPN, and thereby bypassing any firewalls used by my ISP.

answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions