Backup filter by tag not working?

0

I created an AWS Backup job to backup all EBS volumes and I wanted to exclude all volumes ending with the word "swap" in the Name. I tried the tag filtering option and specified only backup volumes if the Name does not end in "swap". Even though we have 3 volumes with Names that end in "swap", they were backed up anyway.

I modified the job last night to tell it to only include volumes if the name does not contain the word "swap". That didn't work either. The resource assignment shows:

Tags - not like
aws:ResourceTag/Name - *swap*

Has this feature just not been properly tested or am I misunderstanding how the Tag filtering for resource assignments is supposed to work?

For what it is worth, here is what the first filter looked like (Name does not end in swap):

Tags - not like
aws:ResourceTag/Name - *swap
Jhoov
asked a year ago498 views
1 Answer
1

Tag Filtering only works with Tags, not with the name. You can do one of the following in the EBS volume tags:

  1. Create a tag called 'Name' in the Key and add the name in the value in all of your EBS volumes and try out you current tag filter in your AWS Backup job.
  2. Create a Tag called 'Backup' and apply it to all of your EBS volumes to say either 'Yes' or 'No', then in the Filtering option you can specify the volumes that only have 'Yes' configured AWS Backup job.
AWS
vtjean
answered a year ago
  • Hi vtjean,

    Thank you for the response. My apologies, I should have specified there is a Tag with the Key = Name. I am trying to use that existing tag for the filter. I know I can add another tag, but I saw the options that specify "Does not contain" and "Does not end with" and thought I would try that so we didn't have to manage additional tags.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions