RDS "Restore from S3" Stuck in "Creating" Status


I am unable to do a "Restore from S3" operation, following the documentation here: https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/MySQL.Procedural.Importing.html I have tried both Aurora and RDS MySQL, and they both get stuck in "Creating" status. I can connect to the instance, and see that the imported data is there. I have examined the logs on the RDS MySQL instance, and see no errors. How can I get unstuck from "Creating" status?

2 Answers


Try running with:

@with_norecovery = 0

and see if that works for you. Setting it to 1 leaves it in a state where you can then restore additional transaction logs etc, or set up replication. If you want the database usable, you need to leave it in an online state, which setting it to 0 should do.

profile pictureAWS
answered 2 years ago
  • I don't think MySQL has an equivalent parameter to SQL Server's @with_norecovery.


I found the cause. In the source database from which the backup was taken, there was a user "admin"@"localhost". When I was choosing the DB create parameters, I accepted the default master user name which was: "admin"@"localhost". This conflict caused the restore to fail on creating the master user and then retry, apparently in an infinite loop. I solved the problem simply by choosing a different name for the master user.

S Evett
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions