Can't connect to my Windows server via Remote desktop.

0

Hello. First time here. First time launching a Windows server on AWS too.

I just created and started the Windows server. I downloaded RDP link for it and run it. It can't connect.

I went to the default security group and added RDP inbound with my IP or anywhere IP but this didn't fix the problem.

Please help.

[Window Title] Remote Desktop Connection

[Content] Remote Desktop can't connect to the remote computer for one of these reasons:

  1. Remote access to the server is not enabled
  2. The remote computer is turned off
  3. The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

[^] Hide details [OK]

[Expanded Information] Error code: 0x204 Extended error code: 0x0

Press Ctrl+C to copy.

Xtro
asked 9 months ago513 views
1 Answer
0

Hi Xtro.

A few things to verify:

  • Is your instance in a public subnet?
  • Does your instance have a public IP?
  • Are the subnet NACLs allowing traffic (inbound and outbound) on port 3389?

More details about connecting to the instance are in the documentation.

I hope this helps.

profile pictureAWS
EXPERT
answered 9 months ago
  • I don't know about subnets yet. Let me see if I can find related settings.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions