Action execution failed InternalError

0

Hi,
I'm running through the CodePipeline Tutorial. Create a Pipeline with an Amazon ECR Source and ECS-to-CodeDeploy Deployment (in the eu-central-1 region)
Source and Deploy stages.
The Deploy stage fails.
Tried changing the configurations here and there.

A couple of the error codes:

Action execution failed
InternalError. Error reference code: 8d667efd-851a-4797-b5e8-91dc269da31b.

Action execution failed
InternalError. Error reference code: 0416a552-758d-435f-a35c-15ec904eba88.

Of course, there may be something which was mis-configured.

How could I debug further? Is there log output?

Thanks,
Sam

asked 5 years ago774 views
2 Answers
0

Solved. Very easy. I just had to continue to the step "add an Amazon ECR source action to your pipeline". Add the ECR source. Maybe in this case "Action execution failed InternalError" could instead say "Expecting a source input in the format of a Docker image such as an ECR source. The pipeline input source was not in that format."

answered 5 years ago
0

Hello! Sorry for the delay in looking at this post.

Thanks for your comments, I agree this is a pretty bad experience because it doesn't give you any information to help fix the issue. I will pass along your comments to the team responsible for this action and ask them to make the error message more useful.

I hope you're enjoying using the ECS action in spite of this problem!

Matthew

answered 5 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions