Issues with Amazon Nitro latest changes: Error E19

0

I have been using Nitro Enclaves for the last 2 months. Then I had to terminate my EC2 instances for a refunding issue. But when I spun up an EC2 today and tried to run the https://github.com/aws/aws-nitro-enclaves-samples/tree/main code in Enclave modem it keeps giving me the below error.

[ec2-user@ip-172-31-14-126 server]$ nitro-cli build-enclave --docker-uri multi-sample-server --output-file multi_server.eif
Start building the Enclave Image...
[ E19 ] File operation failure. Such error appears when the system fails to perform the requested file operations, such as opening the EIF file when launching an enclave, or seeking to a specific offset in the EIF file, or writing to the log file.
File: '/usr/share/nitro_enclaves/blobs//cmdline', failing operation: 'Open'.

For more details, please visit https://docs.aws.amazon.com/enclaves/latest/user/cli-errors.html#E19

If you open a support ticket, please provide the error log found at "/var/log/nitro_enclaves/err2024-03-26T22:15:02.032523546+00:00.log"

The log in the file is given below.

 Action: Build Enclave
  Subactions:
    Failed to build enclave
    Failed to build EIF from docker
    Could not open kernel command line file: Os { code: 2, kind: NotFound, message: "No such file or directory" }
  Root error file: src/lib.rs
  Root error line: 84
  Version: 1.2.3

I am quite confident that I followed the same steps I did before. I mostly follow this article to setup the machine with basic installations.

https://towardsdatascience.com/privacy-preserving-deep-learning-with-aws-nitro-enclaves-74c72a17f857

Bhanuka
asked 2 months ago133 views
2 Answers
1
Accepted Answer

Hello.

Looking at this GitHub issue, it seems that an error occurs if the build package is missing.
How about trying to install the package again?
https://github.com/aws/aws-nitro-enclaves-cli/issues/513

It seems that an error will occur if the memory allocation in "/etc/nitro_enclaves/allocator.yaml" is too large.
https://github.com/aws/aws-nitro-enclaves-cli/issues/282

If it does not improve, could you please share the instance type and EC2 OS you are using?

profile picture
EXPERT
answered 2 months ago
profile picture
EXPERT
reviewed 2 months ago
0

Thanks for pointing out.

Actually, I could not install it but then I thought may be the package is outdated now.

[ec2-user@ip-172-31-14-126 ~]$ sudo amazon-linux-extras install aws-nitro-enclaves-cli-devel -y
Topic aws-nitro-enclaves-cli-devel is not found.

But then because of your comment and the GitHub issue, I tried the yum install and it worked. Consequently, I was able to nitro-cli build-enclave too.

Your answer is spot on.

Bhanuka
answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions