Unable to delete a glacier vault


I have followed all the instructions as per https://docs.aws.amazon.com/amazonglacier/latest/dev/getting-started-delete-archive-cli.html to delete a glacier vault However the vault still appears on the console and I am getting the following error

Error deleting vault
Vault not empty or recently written to: arn:aws:glacier:ap-southeast-2:XXXXXXXX:vaults/testvault
profile picture
asked 2 years ago921 views
1 Answer
Accepted Answer

There should have been no writes to the vault since the last inventory.

S3 Glacier prepares an inventory for each vault periodically, every 24 hours. Because the inventory might not reflect the latest information, S3 Glacier ensures the vault is indeed empty by checking if there were any write operations since the last vault inventory.

So retry after 24 hours :-)

https://docs.aws.amazon.com/amazonglacier/latest/dev/api-vault-delete.html https://docs.aws.amazon.com/amazonglacier/latest/dev/working-with-vaults.html

profile picture
answered 2 years ago
profile picture
reviewed 5 days ago
  • In my case, there are no writes to the vault. I already tried for 3 days, leaving 24 hours in between, and I keep getting the same errors. Thanks

  • Also, my problem is deleting archive. It keeps saying Invalid Vault name even though the vault name is correct. Used the exact same code and aws command than I used with other vaults that worked perfectly. Yet on these two vauts I keep getting the error

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions