Can't connect to SQL Server 2014 Express AMI



When I use the RDP session I only see one Command Prompt window. I don't see a Windows UI. Is this AMI bad?

Additionally, I'm trying to remotely connect to the SQL Server that is provided by this AMI. I have all ports inbound ports open but I can't figure out how to remotely connect and configure it. I can connect to it locally in the RDP session.

Is there a default port for this SQL instance?



asked 4 years ago20 views
3 Answers
Accepted Answer

The AMI contains Windows Server Core Install :, so seeing only Command Prompt is expected.

By default the network services are disabled on SQL Server. Need to restart network services to be able to reach SQL Server (port 1443) from outside server.

Following is the way to enable the networking service:

  1. Use netstat -a -b to verify port 1433 is not LISTENING
  2. Run C:\Windows\SysWOW64\SQLServerManager12.msc from cmd.exe to open SQL Server 2014 Configuration Manager
  3. Follow Steps in Microsoft Article to check the network status, enable, and restart SQL Server
  4. After SQL Server restart, check for port status using netstat -a -b
  5. Should be able to connect from other servers after that, off course assuming the port is allowed.

Hope this helps.

answered 4 years ago

Perfect response! Thank you so much. That's very helpful.

answered 4 years ago

Is there a set of default credentials for remote server management?

I can telnet to the port 1433 and that responds so I know the server is running. I'm not able to figure out the default credentials using the remote management server tool so I can't log in to begin adding databases, etc.

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions