Changing domain from Netlify to AWS Amplify

0

Hello,

I originally bought a domain name from GoDaddy, I then changed the name servers to Netlify's nameservers as I wanted to have my domain name hosted with Netlify as that is where I was hosting my project, so the domain is currently actively being used by Netlify. I have now moved my project onto AWS Amplify and now want to use that same custom domain name for the site hosted with AWS Amplify.

I updated the CNAME records in Netlify so Amplify could verify domain ownership. SSL Configuration was set up successfully but I now get an error when it comes to 'Domain Activation', it says this:

Something went wrong. Please refer to our troubleshooting guide below to diagnose the issue. After fixing the issue, choose retry below. Error message: [AmplifyWaitTimeout] The domain association has failed because we did not find the CNAME verification record on the DNS entries of your domain. Please check our troubleshooting guide for help: https://docs.aws.amazon.com/amplify/latest/userguide/custom-domain-troubleshoot-guide.html

I can't see anything in the docs that helps me with this specific issue as I am using Netlify and not a DNS provider as I had the nameservers changed to Netlify.

Not sure how to go about fixing this, any help would be greatly appreciated.

Thank you!

1 Answer
0

Hi There

If your domain's nameservers point to Netlify DNS, then you need to create the Amplify CNAME records in Netlify's DNS service. See https://docs.netlify.com/domains-https/netlify-dns/dns-records/

If you've already done this, its possible that you may need to wait a few hours for Amplify to recognize the CNAME records.

From the AWS documentation here: https://docs.aws.amazon.com/amplify/latest/userguide/custom-domain-troubleshoot-guide.html#my-domain-hosted-with-a-third-party-is-stuck-in-the-pending-verification-state

It is important to update your CNAME records as soon as you create your custom domain. After your app is created in the Amplify console, your CNAME record is checked every few minutes to determine if it resolves. If it doesn’t resolve after an hour, the check is made every few hours, which can lead to a delay in your domain being ready to use. If you added or updated your CNAME records a few hours after you created your app, this is the most likely cause for your app to get stuck in the Pending Verification state.

You can manually check that your CNAME resolves by following the instructions here: https://docs.aws.amazon.com/amplify/latest/userguide/custom-domain-troubleshoot-guide.html#how-do-i-verify-that-my-cname-resolves

profile pictureAWS
EXPERT
Matt-B
answered 2 months ago
  • Hello Matt,

    Thank you for answering my question!

    So I deleted the domain and tried all over again and I updated the CNAME records in Netlify to validate domain ownership. This enabled the SSL configuration to go Green. I then updated the CNAME and ALIAS records in Netlify DNS for the domain activation to work. However, I am still getting the same error. My domain is currently serving live traffic in Netlify so I am not sure if that is also an issue.

    Amplify says to not update your DNS records if your domain is serving live traffic until a <id>cloudfront.net is live. However, this URL never goes live for me. I am not sure again if this is having an issue.

    I will read through both of these docs and see if this helps!

    Again thank you for responding!

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions