Questions tagged with Reserved Instances

Content language: English

Sort by most recent

Browse through the questions and answers listed below or filter and sort to narrow down your results.

Hi, as per the announcement that these instance types are being deprecated, it is not clear what happens to remaining days already purchased for reserved instances of this older types. I have a db.r3.large instance, and a fully paid for Reserved Instance for that which has 462 days still remaining on it. The announcement email I received simply says "If you have Reserved Instances on M1, M2, M3, R3, or T1, you will be able to cancel them after you create new Reserved Instances for the same value or higher with M5, R5, or T3 respectively." However, what does that mean with respect to the loss of all of those already pre-paid for days on the existing Reserved Instance? Does canceling the Reserved Instance issue me a refund or credit towards the new Reserved Instance?
1
answers
0
votes
17
views
asked 2 days ago
Firing up new RHEL 9 EC2 ARM64 instance, and immediately trying to do a yum update and it can't. It appears the BaseOS is out of sync (older) with the updated Appstream repo. None of my 12 Reserved Instances, running RHEL9, can yum update either. If I disable BaseOS, it doesn't complain. I can't contact RHEL, since RedHAT says AWS handles RedHAT support. I've tried US-EAST-1, US-EAST-2, and US-WEST-2. The Appstream Repo, which provides all of the -devel rpms, has newer, updated rpms, which is complaining about older rpms in the BaseOS. As you can see it wants differing packages for -devel and base versions, which can't happen. Please fix. Thanks! Red Hat Enterprise Linux 9 for aarch64 - AppStream from RHUI (RPMs) 27 MB/s | 13 MB 00:00 Red Hat Enterprise Linux 9 for aarch64 - BaseOS from RHUI (RPMs) 40 MB/s | 6.0 MB 00:00 Red Hat Enterprise Linux 9 Client Configuration 18 kB/s | 1.8 kB 00:00 Error: Problem 1: package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed - cannot install both authselect-1.2.5-2.el9_1.aarch64 and authselect-1.2.5-1.el9.aarch64 - cannot install the best update candidate for package authselect-compat-1.2.5-1.el9.aarch64 - cannot install the best update candidate for package authselect-1.2.5-1.el9.aarch64 Problem 2: package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 - cannot install the best update candidate for package glibc-devel-2.34-40.el9.aarch64 - cannot install the best update candidate for package glibc-2.34-40.el9.aarch64 Problem 3: package zlib-devel-1.2.11-34.el9.aarch64 requires zlib(aarch-64) = 1.2.11-34.el9, but none of the providers can be installed - cannot install both zlib-1.2.11-35.el9_1.aarch64 and zlib-1.2.11-34.el9.aarch64 - cannot install the best update candidate for package zlib-devel-1.2.11-34.el9.aarch64 - cannot install the best update candidate for package zlib-1.2.11-34.el9.aarch64 Problem 4: package libxcrypt-devel-4.4.18-3.el9.aarch64 requires glibc-devel(aarch-64) >= 2.27, but none of the providers can be installed - package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed - package glibc-2.34-40.el9.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-40.el9 if redhat-rpm-config), but none of the providers can be installed - package glibc-2.34-28.el9_0.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0 if redhat-rpm-config), but none of the providers can be installed - package glibc-2.34-28.el9_0.2.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0.2 if redhat-rpm-config), but none of the providers can be installed - cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-40.el9.aarch64 - cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.aarch64 - cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.2.aarch64 - cannot install the best update candidate for package redhat-rpm-config-196-1.el9.noarch - cannot install the best update candidate for package libxcrypt-devel-4.4.18-3.el9.aarch64 - cannot install the best update candidate for package glibc-gconv-extra-2.34-40.el9.aarch64 Problem 5: problem with installed package authselect-compat-1.2.5-1.el9.aarch64 - package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed - package authselect-1.2.5-1.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed - cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.5-1.el9.aarch64 - cannot install the best update candidate for package authselect-libs-1.2.5-1.el9.aarch64 Problem 6: package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed - package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed - package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed - package glibc-2.34-40.el9.aarch64 requires glibc-common = 2.34-40.el9, but none of the providers can be installed - package glibc-2.34-28.el9_0.aarch64 requires glibc-common = 2.34-28.el9_0, but none of the providers can be installed - package glibc-2.34-28.el9_0.2.aarch64 requires glibc-common = 2.34-28.el9_0.2, but none of the providers can be installed - cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-40.el9.aarch64 - cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.aarch64 - cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.2.aarch64 - cannot install the best update candidate for package glibc-common-2.34-40.el9.aarch64 - cannot install the best update candidate for package gcc-11.3.1-2.1.el9.aarch64 Problem 7: problem with installed package glibc-devel-2.34-40.el9.aarch64 - package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed - cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 - package glibc-langpack-en-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed - cannot install the best update candidate for package glibc-langpack-en-2.34-40.el9.aarch64 You can even take the AMI Image directly from RHEL, https://access.redhat.com/solutions/15356 and try and do a yum update, on install and get: [root@ip-172-30-3-97 ~]# yum update Updating Subscription Management repositories. Unable to read consumer identity This system is not registered with an entitlement server. You can use subscription-manager to register. Red Hat Enterprise Linux 9 for aarch64 - AppStream from RHUI (RPMs) 65 MB/s | 13 MB 00:00 Red Hat Enterprise Linux 9 for aarch64 - BaseOS from RHUI (RPMs) 35 MB/s | 6.0 MB 00:00 Red Hat Enterprise Linux 9 Client Configuration 19 kB/s | 1.8 kB 00:00 Error: Problem 1: package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed cannot install both authselect-1.2.5-2.el9_1.aarch64 and authselect-1.2.5-1.el9.aarch64 cannot install the best update candidate for package authselect-compat-1.2.3-7.el9.aarch64 cannot install the best update candidate for package authselect-1.2.3-7.el9.aarch64 Problem 2: problem with installed package authselect-compat-1.2.3-7.el9.aarch64 package authselect-compat-1.2.3-7.el9.aarch64 requires authselect(aarch-64) = 1.2.3-7.el9, but none of the providers can be installed package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed package authselect-1.2.3-7.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.3-7.el9, but none of the providers can be installed package authselect-1.2.5-1.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.3-7.el9.aarch64 cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.5-1.el9.aarch64 cannot install the best update candidate for package authselect-libs-1.2.3-7.el9.aarch64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) If you add --allowerasing, and let it remove authselect-compat on this initial update, then do a: yum group install "development tools", and let it install all the -devel rpms, now you're in for a world of hurt. Any yum updates after that, and with repos out of sync, yum can't update: [root@ip-172-30-3-97 ~]# yum update Updating Subscription Management repositories. Unable to read consumer identity This system is not registered with an entitlement server. You can use subscription-manager to register. Last metadata expiration check: 0:03:07 ago on Thu 26 Jan 2023 09:17:10 PM UTC. Error: Problem 1: package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 cannot install the best update candidate for package glibc-devel-2.34-40.el9.aarch64 cannot install the best update candidate for package glibc-2.34-40.el9.aarch64 Problem 2: package zlib-devel-1.2.11-34.el9.aarch64 requires zlib(aarch-64) = 1.2.11-34.el9, but none of the providers can be installed cannot install both zlib-1.2.11-35.el9_1.aarch64 and zlib-1.2.11-34.el9.aarch64 cannot install the best update candidate for package zlib-devel-1.2.11-34.el9.aarch64 cannot install the best update candidate for package zlib-1.2.11-34.el9.aarch64 Problem 3: package libxcrypt-devel-4.4.18-3.el9.aarch64 requires glibc-devel(aarch-64) >= 2.27, but none of the providers can be installed package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed package glibc-2.34-40.el9.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-40.el9 if redhat-rpm-config), but none of the providers can be installed package glibc-2.34-28.el9_0.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0 if redhat-rpm-config), but none of the providers can be installed package glibc-2.34-28.el9_0.2.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0.2 if redhat-rpm-config), but none of the providers can be installed cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-40.el9.aarch64 cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.aarch64 cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.2.aarch64 cannot install the best update candidate for package redhat-rpm-config-196-1.el9.noarch cannot install the best update candidate for package libxcrypt-devel-4.4.18-3.el9.aarch64 cannot install the best update candidate for package glibc-gconv-extra-2.34-40.el9.aarch64 Problem 4: package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed package glibc-2.34-40.el9.aarch64 requires glibc-common = 2.34-40.el9, but none of the providers can be installed package glibc-2.34-28.el9_0.aarch64 requires glibc-common = 2.34-28.el9_0, but none of the providers can be installed package glibc-2.34-28.el9_0.2.aarch64 requires glibc-common = 2.34-28.el9_0.2, but none of the providers can be installed cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-40.el9.aarch64 cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.aarch64 cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.2.aarch64 cannot install the best update candidate for package glibc-common-2.34-40.el9.aarch64 cannot install the best update candidate for package gcc-11.3.1-2.1.el9.aarch64 Problem 5: problem with installed package glibc-devel-2.34-40.el9.aarch64 package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 package glibc-langpack-en-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed cannot install the best update candidate for package glibc-langpack-en-2.34-40.el9.aarch64 Problem 6: package annobin-10.73-3.el9.aarch64 requires (gcc >= 11 with gcc < 12), but none of the providers can be installed package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64 cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-28.el9_0.aarch64 cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-28.el9_0.2.aarch64 package gcc-11.2.1-9.4.el9.aarch64 requires cpp = 11.2.1-9.4.el9, but none of the providers can be installed package glibc-minimal-langpack-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed cannot install both cpp-11.2.1-9.4.el9.aarch64 and cpp-11.3.1-2.1.el9.aarch64 cannot install the best update candidate for package glibc-minimal-langpack-2.34-40.el9.aarch64 cannot install the best update candidate for package cpp-11.3.1-2.1.el9.aarch64 cannot install the best update candidate for package annobin-10.73-3.el9.aarch64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest'
0
answers
0
votes
8
views
asked 2 days ago
Hi, my website (kenniescompass.com) is down. And we got the following email from lightsail... We have detected a degradation of the underlying hardware hosting your instance: kenniescompass.com (us-east-1) in your AWS Account with ID: 722687524582. Due to this degradation, we will have to perform necessary maintenance to the underlying hardware. Your instance may already be unreachable. Maintenance activity will result in your Lightsail instance stopping after Wed, 18 Jan 2023 20:00:00 GMT. After your instance is stopped, you can restart it at any time. what does this mean? How do i fix it immediately to get my website back up and running?
1
answers
0
votes
22
views
asked 22 days ago
I am receiving notifications that my cpu power is not sufficient. I have an r5dnLarge instance. My instance has 29 months left on the reserved instance contract. Can I increase my CPU on this instance and still keep the reserved instance contract?
1
answers
0
votes
26
views
asked 25 days ago
how do i need to change the "Reserved Instance" type from t2.micro to t2.medium.
1
answers
0
votes
17
views
asked a month ago
Hello guys, need to know which service is better for hosting a static website, an ECS (fargate), or EC2 Reserved Instances. Thanks.
3
answers
0
votes
91
views
asked a month ago
My question is how to modify the Reserved Instance type without any downtime such as (t3.medium to t3.large).
2
answers
0
votes
40
views
asked a month ago
Can someone help me to understand the instance reservation recommendations provided by the AWS Cost Management? For instance, we make use of the following EC2 instances: 2x m5.large 3x t2.small 1x t3.medium But, the reservation recommendations are: Buy 2 m5.large Buy 12 t2.nano Buy 8 t3.nano Why? Why wouldn't I just buy the exact number and type of instances that we use? Where do these t2.nano (12!) and t3.nano (8) recommendations come from? Supposedly this is based on the last 30 days of our actual usage, but our usage has been exactly as above for quite a long time. We also use Lambda functions.... but I don't think reservations can cover Lambda usage, right? Similarly odd recommendations are for our RDS and OpenSearch usage -- the recommendations only partially match our actual usage. And to be clear -- our actual usage has been stable for a long time. Any ideas?
Accepted AnswerReserved Instances
1
answers
0
votes
27
views
asked a month ago
My question is assume you have bought 1 EC2 Instance family (t3) were all instance types are covered such as (t3.nano, t3.micro, t3.small, t3.medium, t3.large, t3.xlarge t3.2xlarge), and incase i am still in need of extra 2(t3.xlarge) & 1(t3.large), how should i match with the EC2 savings plan?
1
answers
0
votes
31
views
asked a month ago
We have a lot of reserved instances and on-demand instances. How do I generate a monthly report for all RI and all on-demand servers?
1
answers
0
votes
39
views
asked a month ago
I'd like to assign cost allocation tags to certain api operations that appear as untagged when i look at them in cost explorer? I think some of these are related to upfront charges for reserved instances. I can't seem to find a way to assign tags to these in the AWS docs. How do I do it?
1
answers
0
votes
76
views
asked a month ago
Hi, I'm currently running a t2.micro on the free tier and I like what I've seen so far. I'm considering purchasing at least one more t2.micro. I'm trying to figure out the most cost effective way to do that. I have a little experience with reserved instances, but I found out the hard way that storage isn't included. So my question is this. If I want to replicate the instance I have running in the free tier, what's the most cost effective way to do that? If that's a reserved instance, how do I purchase the storage I need? Is it on-demand pricing at the point I create the new instance? Finally, is there anything else I need to purchase? Thanks in advance. crock77
2
answers
0
votes
43
views
crock77
asked a month ago