AWS Connect error - Application has not been enabled for your directory

0

【以下的问题经过翻译处理】 我正在尝试部署下面的AWS Connect解决方案,并在应用程序UI方面遇到问题

解决方案-https://aws.amazon.com/solutions/implementations/ai-powered-speech-analytics-for-amazon-connect

问题1-当我启动UI时,对于代理辅助部分,在浏览器中我会收到以下错误消息 "To protect your security, ***.awsapps.com will not allow Firefox to display the page if another site has embedded it.

在开发者工具中,我可以看到以下错误- [HTTP/1.1 403 Forbidden 0ms] The loading of “https://*******/connect/login” in a frame is denied by “X-Frame-Options“ directive set to “SAMEORIGIN“.

我已在S3存储桶以及CloudFront上启用了CORS。

问题2-如果我在不同的选项卡或新浏览器中打开链接,我会收到错误消息 "Access Error This application has not been enabled for your directory. Please contact your Administrator for more details." 我已在Connect UI以及CloudFront中添加了来源。

profile picture
专家
已提问 2 年前134 查看次数
1 回答
0

【以下的回答经过翻译处理】 我已经解决了这个问题。这是由于解决方案中的连接url使用了旧格式所导致的。这意味着如果Connect实例是最近创建的,则需要手动更新agentAssist.html文件。

文件可以在repo的此处找到:https://github.com/amazon-connect/ai-powered-speech-analytics-for-amazon-connect/blob/main/source/web_site/agentAssist.html 部署位置为s3://{YOUR_BUCKET_NAME}/CCP/agentAssist.html

需要更新的行是405/406 var loginURL = https://${instanceAlias}.awsapps.com/connect/login; var ccpURL = https://${alias}.awsapps.com/connect/ccp-v2/softphone;

要与新实例一起使用,需要更改为: var loginURL = https://${instanceAlias}.my.connect.aws/login; var ccpURL = https://${alias}.my.connect.aws/ccp-v2/softphone;

您可以手动覆盖S3存储桶中的此文件,但一定要等待Cloudfront缓存清除或自行使其无效。

profile picture
专家
已回答 2 年前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则