设置Elastic Beanstalk Node.js平台的小版本号。

0

【以下的问题经过翻译处理】 这些文档:https://docs.aws.amazon.com/elasticbeanstalk/latest/platforms/platform-history-nodejs.html 请注意可用于给定平台版本(如 Node.js 12 AL2 版本 5.4.8)的 node.js 的不同次要版本。你如何设置将使用的次要版本(比如 v12.20.2?)

谢谢!

profile picture
专家
已提问 8 个月前37 查看次数
1 回答
0

【以下的回答经过翻译处理】 每个Node.js平台版本都支持几个Node.js语言版本。有效的Node.js版本,以及默认版本。每个Node.js版本都包括相应版本的npm(Node.js包管理器)。

在Amazon Linux 2平台版本上,只有默认的Node.js版本预安装。您可以在项目源的根目录中使用package.json文件来指定您希望应用程序使用的Node.js版本。请参阅https://docs.aws.amazon.com/elasticbeanstalk/latest/dg/nodejs-platform-packagejson.html

在Amazon Linux AMI平台版本(在Amazon Linux 2之前),所有列出的平台版本支持的Node.js版本都预先安装在其中。当aws:elasticbeanstalk:container:nodejs命名空间中的NodeVersion选项未设置时,默认Node.js版本适用。请参阅https://docs.aws.amazon.com/elasticbeanstalk/latest/dg/command-options-specific.html#command-options-nodejs

更多信息,特别是一些要注意的问题,请查看https://docs.aws.amazon.com/elasticbeanstalk/latest/platforms/platforms-supported.html#platforms-supported.nodejs

profile picture
专家
已回答 8 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则