最新的mqtt.Bridge(2.2.3)与最新的clientdevices.Auth(3.3.0)不兼容。

0

【以下的问题经过翻译处理】 我正在尝试部署以下AWS组件的最新版本:

“aws.greengrass.Nucleus”:{
      “componentVersion”:“2.9.1”
    },
    “aws.greengrass.Cli”:{
      “componentVersion”:“2.9.1”
    },
    “aws.greengrass.LocalDebugConsole”:{
      “componentVersion”:“2.2.7”
    },
    “aws.greengrass.LogManager”:{
      “componentVersion”:“2.3.0”
    },
    “aws.greengrass.clientdevices.mqtt.Moquette”:{
      “componentVersion”:“2.3.0”
    },
    “aws.greengrass.clientdevices.mqtt.Bridge”:{
      “componentVersion”:“2.2.3”
    },
    “aws.greengrass.clientdevices.Auth”:{
      “componentVersion”:“2.3.0”
    },
    “aws.greengrass.TokenExchangeService”:{
      “componentVersion”:“2.0.3”
    },
    “aws.greengrass.ShadowManager”:{
      “componentVersion”:“2.2.3”
    },
    “aws.greengrass.telemetry.NucleusEmitter”:{
      “componentVersion”:“1.0.5”
    }

但我得到了以下版本异常:

{componentName=aws.greengrass.clientdevices.Auth, versionRequirement={aws.greengrass.clientdevices.mqtt.Moquette=>=2.2.0 <2.4.0, thing/greengrassv2_greglaptop-253==2.3.0, aws.greengrass.clientdevices.mqtt.Bridge=>=2.2.0 <2.3.0, com.arthrex.s2p-GgLifecycle=>=2.0.3 <3.0.0}}
2022-11-21T18:01:53.785Z [ERROR] (pool-2-thread-67) com.aws.greengrass.deployment.DeploymentService: Error occurred while processing deployment. {deploymentId=4d34f866-0174-4e1a-8842-aa614652690e, serviceName=DeploymentService, currentState=RUNNING}
java.util.concurrent.ExecutionException: com.aws.greengrass.componentmanager.exceptions.NoAvailableComponentVersionException: No local or cloud component version satisfies the requirements Check whether the version constraints conflict and that the component exists in your AWS account with a version that matches the version constraints. If the version constraints conflict, revise deployments to resolve the conflict. Component aws.greengrass.clientdevices.Auth version constraints: aws.greengrass.clientdevices.mqtt.Moquette requires >=2.2.0 <2.4.0, thing/greengrassv2_greglaptop-253 requires =2.3.0, aws.greengrass.clientdevices.mqtt.Bridge requires >=2.2.0 <2.3.0
profile picture
专家
已提问 6 个月前48 查看次数
1 回答
0

【以下的回答经过翻译处理】 你好,2.2.3不是桥接器的最新版本,请使用最新版本的桥接器,它将会工作。最新版本是2.2.4。

你可以在Greengrass组件页面的“公共组件”下始终找到最新版本。

祝好, 迈克尔

profile picture
专家
已回答 6 个月前

您未登录。 登录 发布回答。

一个好的回答可以清楚地解答问题和提供建设性反馈,并能促进提问者的职业发展。

回答问题的准则