Unable to connect to Remote Desktop


I connected to my t2 instance till yesterday evening but today when I tried to connect, it wouldnt let me.


[Window Title]
Remote Desktop Connection

Remote Desktop can't connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

[^] Hide details  [OK]

[Expanded Information]
Error code: 0x204
Extended error code: 0x0
Timestamp (UTC): 02/28/24 07:15:45 AM

I havent made any changes to my instance except reattaching it from my T3.medium which I do regularly as per necessity, without issues. While attaching it, I made sure I assigned the root vol name /dev/sda1 since that caused a minor issue a couple of weeks ago. I disabled my AV to make sure my firewall wasnt blocking the connection. I also checked the ports on 80 & 3389 are connected so I have no clue whats going wrong. I read some of the similar questions posted here but cant find anything specific that would offer some help.

已提问 3 个月前179 查看次数
3 回答

Ive already terminated the instance and launched a new one.

The public IP address of the EC2 instance will be different for your new instance, ensure you're connecting to the correct IP address.

The password will be different too (although I know that you're not even able to establish the initial connection right now).

Has the IP address of the local device changed? If it has then the security group may need to be updated to reflect this? It may be worth opening 3389/tcp from while troubleshooting, you can always tighten this up later.

In the AWS Console is the Status check of the instance showing 2/2 checks passed ?

Depeding on the region, you may be able to select the instance and selecting Actions -> Monitor & troubleshoot -> Get instance screenshot. This should show you the system console, does this look like the system is running?

profile picture
已回答 3 个月前
  • I launched a new instance and the problem was still there. So I deleted everything including the security group and key pair and started afresh. Its working now. The only thing was I had to redo the custom settings on the ebs and reinstall the applications.

    Come to think of it, its possible there was something to do with the security group because only after I deleted it, and created a new instance did it finally work. But my ip had not changed. I have been on a static ip for 5 years.

profile picture
已回答 3 个月前
  • Im not certain its an issue listed in one of these. I deleted the old t2 instance with its corresponding ebs and created a new one with the existing key pair and security. The issue is the same - error connecting to rdp.

  • Is a route to the Internet gateway set in the route table of the subnet where EC2 is running? Also, is RDP allowed in the inbound rules of the security group in EC2? Please also check that all communication is permitted in the network ACL of the subnet where EC2 is running.

  • As far as I can see, RDP is allowed in the inbound rules under security tab. Where do I find the route to the internet gateway? Instance id: i-08333163856d5f233

  • You can check the subnet ID where EC2 is running from the EC2 networking tab. a
    Click on the subnet ID to check the details of the subnet. If the route to the Internet gateway is set, the settings should look like the image below. b

  • Is it possible region Im connected to is experiencing some kind of downtime?

    I don't think there are any failure reports from AWS so far. By the way, are the username and password used for RDP connection correct? If you recreated EC2, the Administrator password should have changed, so you need to confirm it again using the key pair.


Yes the route has been set in that case, and I still cannot connect. Is it possible region Im connected to is experiencing some kind of downtime? Ive already terminated the instance and launched a new one. So I dont know what else I can do.

Enter image description here

已回答 3 个月前

您未登录。 登录 发布回答。