Invalid InputTemplate for target


I´m trying to test this

Input path:

  "requester": "$.detail.requester",
  "key": "$.detail.object.key",
  "bucket": "$"

Input template:

    "<requester> has created the object \"<key>\" in the bucket \"<bucket>\"",
    "RuleName": <>,
    "ruleArn" : <>,
    "Transformed": "Yes"

but I´m getting this error message: Invalid InputTemplate for target Id1723290b-5086-4e82-ab16-5605fd17fb0e : [Source: (String)"{ "null has created the object "null" in the bucket "null"", "RuleName": null, "ruleArn" : null, "Transformed": "Yes" }"; line: 2, column: 67].

Any ideas why? thanks a lot

profile pictureAWS
已提问 4 个月前202 查看次数
1 回答


I was able to confirm in my environment that the input template etc. worked with the settings as described in the document.
Maybe something went wrong when copy-pasting.
Try typing it manually instead of copy-pasting.
Also, be sure to select "S3 Object Created" for the sample event.

profile picture
已回答 4 个月前
  • Don´t know why this input template hasn´t worked for me, had to add a ":" and string at the end of 1st line.

    Something like this:

    { "<requester> has created the object "<key>" in the bucket "<bucket>"": "string", "RuleName": <>, "ruleArn" : <>, "Transformed": "Yes" }

您未登录。 登录 发布回答。